Bug 492163 - Enable CONFIG_MOUSE_PS2_ELANTECH
Enable CONFIG_MOUSE_PS2_ELANTECH
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 13:14 EDT by Oskari Saarenmaa
Modified: 2009-04-01 01:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 01:42:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oskari Saarenmaa 2009-03-25 13:14:25 EDT
Description of problem:
CONFIG_MOUSE_PS2_ELANTECH is required for EeePC 901 touchpad to be usable with the synaptics driver.

Version-Release number of selected component (if applicable):
kernel-PAE-2.6.29-0.258.rc8.git2.fc11.i686
Comment 1 Chuck Ebbert 2009-03-25 23:49:13 EDT
I'm not sure the xorg driver in f11 can handle that:

config MOUSE_PS2_ELANTECH
        bool "Elantech PS/2 protocol extension"
        depends on MOUSE_PS2
        help
          Say Y here if you have an Elantech PS/2 touchpad connected
          to your system.

          Note that if you enable this driver you will need an updated
          X.org Synaptics driver that does not require ABS_PRESSURE
          reports from the touchpad (i.e. post 1.5.0 version). You can
          grab a patch for the driver here:

          http://userweb.kernel.org/~dtor/synaptics-no-abspressure.patch

          If unsure, say N.

          This driver exposes some configuration registers via sysfs
          entries. For further information,
          see <file:Documentation/input/elantech.txt>.

# koji latest-pkg dist-f11 xorg-x11-drv-synaptics
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
xorg-x11-drv-synaptics-1.1.0-1.fc11       dist-f11              whot
Comment 2 Peter Hutterer 2009-03-26 00:07:22 EDT
It does, the documentation in the kernel is wrong. first released version with elantech support was 1.0.


Upstream commit (xf86-input-synaptics):
commit 2acbd6e67c859290a37cf3134b120c5ca7577268
Refs: xf86-input-synaptics-0.15.2-30-g2acbd6e
Author:     Dmitry Torokhov <dmitry.torokhov@gmail.com>
AuthorDate: Tue Oct 28 17:10:45 2008 +1030

    Add support for touchpads (such as Elantech) that do not report pressure

    Change the driver to react to BTN_TOUCH if device does not report
    ABS_PRESSURE since there are touchpads (such as Elantech) that do not
    support pressure reading but otherwise are perfectly useable in absolute
    mode.
Comment 3 Oskari Saarenmaa 2009-03-26 03:02:33 EDT
Yeah, I can confirm that it works, I just built "kernel-PAE-2.6.29-2.os2.fc11.i686.rpm" with the option set and the driver works fine.
Comment 4 Dave Jones 2009-03-26 14:05:48 EDT
enabled in cvs.
Comment 5 Casey Jones 2009-03-31 00:35:09 EDT
I can also confirm this on my Eee PC 900.
If I use the kernel from the F11 Alpha, it works fine, but using the latest kernel breaks tap-to-click.  So I'm guessing somewhere down the line this option got disabled.  Is there an ETA on when this will hit Rawhide?
Comment 6 Oskari Saarenmaa 2009-03-31 03:30:00 EDT
It's already in rawhide (kernel-2.6.29-16.fc11).
Also disabling tap to click is part of the "SynapticsUpdate" feature in Fedora 11, see http://fedoraproject.org/wiki/Features/SynapticsUpdate

Note You need to log in before you can comment on or make changes to this bug.