Bug 492170 - bug to track monitoring email notifications
bug to track monitoring email notifications
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
wes hayutin
na
:
Depends On:
Blocks: 285651 463877
  Show dependency treegraph
 
Reported: 2009-03-25 14:12 EDT by wes hayutin
Modified: 2009-09-10 14:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 492169
Environment:
Last Closed: 2009-09-10 14:49:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ss of monitoring email (209.28 KB, image/png)
2009-06-05 09:35 EDT, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2009-03-25 14:12:41 EDT
+++ This bug was initially created as a clone of Bug #492169 +++

Description of problem:

currently probes are not sending email notifications.
Unfortunately I dont have any details right now.

recreate:
1. setup monitoring in spacewalk
2. create a probe that you know will go critical
3. setup the probe to send email notifications
4. wait for the probe to go critical

check your inbox...

right now we are not getting notifications.
Comment 1 Miroslav Suchý 2009-03-26 04:50:10 EDT
Root of the problems are probabaly the same as https://bugzilla.redhat.com/show_bug.cgi?id=490783#c4
Leaving to trace it, since it is serious symptom.
Comment 2 Miroslav Suchý 2009-06-03 10:41:40 EDT
this should work now. passing to qa
Comment 3 Miroslav Suchý 2009-06-05 08:58:00 EDT
Moving ON_QA
QA Build: 20090529
Comment 4 wes hayutin 2009-06-05 09:35:28 EDT
Created attachment 346649 [details]
ss of monitoring email

I think we can easily make the emails a little more professional looking.. :)
Comment 5 wes hayutin 2009-06-05 09:37:18 EDT
great!! emails are working but not quite well enough to pass QA

Sending back to dev to get their opinion on:
1. adding a subject to the emails.
2. chaning the sender email address from <rogerthat01@redhat.com> to a real user on the box like nocpulse, root or something.

thanks
Comment 6 Miroslav Suchý 2009-06-05 10:20:35 EDT
err of course QA build 20090605
Comment 7 Miroslav Suchý 2009-06-05 10:49:30 EDT
No it should be rogerthat01, according to documentation you may want to setup notification acknowledgement. Although it is currently not working. See Bug 493028
Comment 8 wes hayutin 2009-06-08 12:22:44 EDT
nice.. working..

This is RHN Monitoring Satellite notification 01hkb0rd.

Time:      Mon Jun 08, 12:18:41 EDT
State:     CRITICAL
Host:      dhcp77-159.rhndev.redhat.com (10.10.77.159)
Check:     Linux: Load
Message:   CPU load 5-min ave 0.07 (above critical threshold of 0.01); CPU load 15-min ave 0.16 (above critical threshold of 0.01); CPU load 1-min ave 0.00

Run from:  RHN Satellite Monitoring Scout

6/05
Comment 9 Tomas Lestach 2009-09-09 11:29:02 EDT
Receiving notifications ... f.e:
========================================================
This is RHN Monitoring Satellite notification 01jcrxxd.

Time:      Wed Sep 09, 10:17:38 EDT
State:     CRITICAL
Host:      dhcp77-134.rhndev.redhat.com (10.10.77.134)
Check:     General: TCP Check
Message:   TCP port 1: connect: Connection refused
Notification #16 for connect: Connection refused

Run from:  RHN Satellite Monitoring Scout
========================================================

Stage validated -> RELEASE_PENDING
Comment 10 Brandon Perkins 2009-09-10 14:49:20 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.