Bug 492171 - Review Request: rubygem-locale - Pure ruby library which provides basic APIs for localization
Review Request: rubygem-locale - Pure ruby library which provides basic APIs ...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Silas Sewell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 14:13 EDT by Mamoru TASAKA
Modified: 2010-12-27 19:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 00:49:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
silas: fedora‑review+
tibbs: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2009-03-25 14:13:04 EDT
Spec URL: http://mtasaka.fedorapeople.org/Review_request/rubygem-locale/rubygem-locale.spec
SRPM URL: http://mtasaka.fedorapeople.org/Review_request/rubygem-locale/rubygem-locale-2.0.0-1.fc.src.rpm
Description: 
Ruby-Locale is the pure ruby library which provides basic and general purpose
APIs for localization.
It aims to support all environments which ruby works and all kind of programs
(GUI, WWW, library, etc), and becomes the hub of other i18n/l10n libs/apps to 
handle major locale ID standards. 

Koji build
- for dist-f11:
  http://koji.fedoraproject.org/koji/taskinfo?taskID=1258487
- for dist-f10-updates-candidate:
  http://koji.fedoraproject.org/koji/taskinfo?taskID=1258492

Note:
There are many rpmlint warnings on ruby-locale subpakage,
however these disappears once ruby-locale is installed.
Comment 1 Silas Sewell 2009-03-28 12:07:19 EDT
Per review requirement:

$ rpmlint /var/lib/mock/fedora-10-i386/result/rubygem-locale-2.0.0-1.fc10.src.rpm 
1 packages and 0 specfiles checked; 0 errors, 0 warnings.
$ rpmlint /var/lib/mock/fedora-10-i386/result/rubygem-locale-2.0.0-1.fc10.noarch.rpm 
1 packages and 0 specfiles checked; 0 errors, 0 warnings.
 rpmlint /var/lib/mock/fedora-10-i386/result/rubygem-locale-doc-2.0.0-1.fc10.noarch.rpm 
rubygem-locale-doc.noarch: W: no-documentation
1 packages and 0 specfiles checked; 0 errors, 1 warnings.
 rpmlint /var/lib/mock/fedora-10-i386/result/ruby-locale-2.0.0-1.fc10.noarch.rpm 
ruby-locale.noarch: W: no-documentation
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/version.rb ../../../gems/1.8/gems/locale-2.0.0/lib/locale/version.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/driver/cgi.rb ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/driver/cgi.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/tag/simple.rb ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/tag/simple.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/taglist.rb ../../../gems/1.8/gems/locale-2.0.0/lib/locale/taglist.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/driver/posix.rb ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/driver/posix.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/driver/win32_table.rb ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/driver/win32_table.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/info/region.rb ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/info/region.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/info.rb ../../../gems/1.8/gems/locale-2.0.0/lib/locale/info.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/data/languages.tab.gz ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/data/languages.tab.gz
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/driver/win32.rb ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/driver/win32.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/tag/rfc.rb ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/tag/rfc.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/info/language.rb ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/info/language.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/tag/common.rb ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/tag/common.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/driver/env.rb ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/driver/env.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/tag/posix.rb ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/tag/posix.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/util/memoizable.rb ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/util/memoizable.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/tag/cldr.rb ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/tag/cldr.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/data/regions.tab.gz ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/data/regions.tab.gz
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/driver/jruby.rb ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/driver/jruby.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/tag.rb ../../../gems/1.8/gems/locale-2.0.0/lib/locale/tag.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale/tag/illegular.rb ../../../../gems/1.8/gems/locale-2.0.0/lib/locale/tag/illegular.rb
ruby-locale.noarch: W: dangling-relative-symlink /usr/lib/ruby/site_ruby/1.8/locale.rb ../../gems/1.8/gems/locale-2.0.0/lib/locale.rb
1 packages and 0 specfiles checked; 0 errors, 23 warnings.

  Confirmed these were all meet by rubygem-local RPM.
Comment 2 Silas Sewell 2009-03-28 12:09:19 EDT
------------------------------------------------------
  This package (rubygem-locale) is APPROVED by silas  
------------------------------------------------------
Comment 3 Mamoru TASAKA 2009-03-28 13:21:23 EDT
Thank you!

New Package CVS Request
=======================
Package Name:       rubygem-locale
Short Description:  Pure ruby library which provides basic APIs for localization
Owners:             mtasaka
Branches:           (devel only)
InitialCC:          (nobody)

I decided not to import this package into F-10 for now.
Comment 4 Kevin Fenzi 2009-03-30 17:42:21 EDT
cvs done.
Comment 5 Mamoru TASAKA 2009-03-31 00:49:02 EDT
Rebuilt on F-11, closing.

Thank you for the review and CVS procedure.
Comment 6 Michael Stahnke 2010-12-27 11:07:32 EST
Package Change Request
======================
Package Name: rubygem-locale
New Branches: el5, el6
Owners: stahnma
InitialCC:
Comment 7 Michael Stahnke 2010-12-27 11:08:12 EST
Forgot to mention that Mamoru Tasaka has allowed me to put any of his packages into EPEL if I maintain them.
Comment 8 Jason Tibbitts 2010-12-27 19:48:36 EST
Git done (by process-git-requests).

Note You need to log in before you can comment on or make changes to this bug.