Bug 492175 - nouveau does not do dynamic framebuffer reallocation for multihead setups
nouveau does not do dynamic framebuffer reallocation for multihead setups
Status: CLOSED DUPLICATE of bug 487356
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 14:24 EDT by Jan ONDREJ
Modified: 2009-03-29 21:05 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 18:39:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2009-03-25 14:24:25 EDT
Description of problem:
When trying to set virtual resolution on multihead configuration to resolution larger than 1680x1680, then it shows information, that I can't. On current displays this is not very large and I don't know, why this application can't allow me to set larger resolution.

May be I should report this bug to nouveau driver, I am not sure.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. set 1. display to 1280x1024
2. set 2. display to 1280x1024
3. apply
  
Actual results:
fails, I have no exact message now.

Expected results:
set display
Comment 1 Adam Williamson 2009-03-26 14:17:32 EDT
This is a driver issue, nothing to do with GNOME.

Ben, it seems nouveau has the same problem intel used to have: it sets a square framebuffer the size of the largest dimension of the primary display, which is obviously not enough for multihead. What's the deal here? Is dynamic framebuffer reallocation planned? Does the old intel dodge of a Virtual line in xorg.conf get around the problem?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Ben Skeggs 2009-03-26 18:39:52 EDT
Yeah, it's the same problem as intel had before framebuffer resize.  It's planned, but not currently viable in most situations.  I could probably implement it for pre-nv5x cards very quickly for brave users that want to test some other mostly untested code at the same time.

Adding a Virtual line will work around the issue.

*** This bug has been marked as a duplicate of bug 487356 ***

Note You need to log in before you can comment on or make changes to this bug.