Bug 492239 - [nouveau] Making video Fullscreen in Totem while video is paused results doesn't resize the video correctly
[nouveau] Making video Fullscreen in Totem while video is paused results does...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 22:56 EDT by Stewart Adam
Modified: 2009-03-29 21:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-29 21:45:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Picture of screen while video is paused (fullscreen) but not resized (222.69 KB, image/jpeg)
2009-03-25 22:58 EDT, Stewart Adam
no flags Details

  None (edit)
Description Stewart Adam 2009-03-25 22:56:36 EDT
Description of problem:
When a video is paused and fullscreen mode is enabled, the video doesn't resize correctly and a grey background is displayed on 3/4 of the playback area. As soon as another window opens or if I resume video playback (perhaps because the redraw of the GTK widget is triggered), then the image appears resized to the entire screen's size as expected.

Version-Release number of selected component (if applicable):
Fedora Test Day 2009-03-25 Live CD

How reproducible:
Always

Steps to Reproduce:
1. Open video file, pause video at any point
2. Enable fullscreen <-- Problem happens here
3. Resume video <-- After this, everything is OK
  
Actual results:
Video is not resized as expected

Expected results:
Video is resized to fit entire screen

Additional info:
Comment 1 Stewart Adam 2009-03-25 22:58:23 EDT
Created attachment 336736 [details]
Picture of screen while video is paused (fullscreen) but not resized
Comment 2 Adam Williamson 2009-03-27 16:30:02 EDT
I've just tested and this doesn't happen with the proprietary driver on today's Rawhide for me, so it doesn't seem like a general Totem / gstreamer bug, but indeed something specific to nouveau.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Ben Skeggs 2009-03-29 21:45:08 EDT
Thanks for the report.  The bug should now be fixed in rawhide, you can test the build at http://koji.fedoraproject.org/koji/taskinfo?taskID=1264787 if you wish.

Note You need to log in before you can comment on or make changes to this bug.