Bug 492240 - [nouveau] Unreadable display with wrong colors when modesetting is enabled
[nouveau] Unreadable display with wrong colors when modesetting is enabled
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 23:07 EDT by Stewart Adam
Modified: 2009-04-15 21:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 20:27:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDM login screen with nouveau.modesetting=1 (194.54 KB, image/jpeg)
2009-03-25 23:07 EDT, Stewart Adam
no flags Details
Plymouth boot splash screen with nouveau.modesetting=1 (94.93 KB, image/jpeg)
2009-03-25 23:08 EDT, Stewart Adam
no flags Details
Kernel complaining about nouveau.modeset being unknown (316.14 KB, image/jpeg)
2009-03-26 11:14 EDT, Jared Smith
no flags Details
Bad colors with nouveau.modeset=1 (309.32 KB, image/jpeg)
2009-03-26 11:21 EDT, Jared Smith
no flags Details
Bad colors with nouveau.modeset=1, zoomed in (285.84 KB, image/jpeg)
2009-03-26 11:22 EDT, Jared Smith
no flags Details
/var/log/messages with nouveau.modeset=1 and drm.debug=1 (2.47 MB, text/plain)
2009-03-26 18:38 EDT, Jared Smith
no flags Details
/var/log/messages with nouveau.modeset=1 and drm.debug=1 (gzipped) (934.00 KB, application/x-gzip)
2009-03-29 13:39 EDT, Stewart Adam
no flags Details

  None (edit)
Description Stewart Adam 2009-03-25 23:07:55 EDT
Created attachment 336737 [details]
GDM login screen with nouveau.modesetting=1

Description of problem:
When enabling kernel mode settings, the display is mostly unreadable and the colors are wrong.

Version-Release number of selected component (if applicable):
Fedora Test Day 2009-03-25 Live CD

How reproducible:
Always

Steps to Reproduce:
1. Boot with nouveau.modesetting=1
  
Actual results:
Display is mostly unreadable, colors wrong

Expected results:
Normal display output

Additional info:
See attached pictures
Comment 1 Stewart Adam 2009-03-25 23:08:56 EDT
Created attachment 336738 [details]
Plymouth boot splash screen with nouveau.modesetting=1
Comment 2 Ben Skeggs 2009-03-25 23:23:07 EDT
Are you able to boot with "nouveau.modeset=1 drm.debug=1" and attach the resulting /var/log/messages to this bug?
Comment 3 Stewart Adam 2009-03-26 00:00:32 EDT
Will do tomorrow - thanks for the quick reply!
Comment 4 Jared Smith 2009-03-26 11:12:38 EDT
I'm seeing the same thing on a GeForce 8600M GT (rev a1) on a Macbook Pro.  I'll attach three photos (of poor quality, unfortunately) showing what I'm seeing.

In short, I don't see the plymouth boot, and the colors are all wrong once X comes up.

I too will try with "nouveau.modeset=1 drm.debug=1" and attach the
resulting /var/log/messages.
Comment 5 Jared Smith 2009-03-26 11:14:13 EDT
Created attachment 336823 [details]
Kernel complaining about nouveau.modeset being unknown

The kernel complains that this is an unkown boot option, but apparently sees it OK anyway.
Comment 6 Jared Smith 2009-03-26 11:21:10 EDT
Created attachment 336827 [details]
Bad colors with nouveau.modeset=1

This photo shows the bad colors in X with the noueveau.modeset=1 kernel command-line option.
Comment 7 Jared Smith 2009-03-26 11:22:12 EDT
Created attachment 336829 [details]
Bad colors with nouveau.modeset=1, zoomed in

In this photo, I zoomed in a bit so you could see that you can barely make out the text and icons on the screen, and that it isn't just random colors.
Comment 8 Jared Smith 2009-03-26 18:38:50 EDT
Created attachment 336923 [details]
/var/log/messages with nouveau.modeset=1 and drm.debug=1

Here is my /var/log/messages file after booting with both nouveau.modeset=1 and drm.debug=1 on the kernel command line.
Comment 9 Stewart Adam 2009-03-29 13:39:13 EDT
Created attachment 337177 [details]
/var/log/messages with nouveau.modeset=1 and drm.debug=1 (gzipped)

Here's my /var/log/messages file. I gzipped it since the original was huge (just over 12 MB)!
Comment 10 Ben Skeggs 2009-03-30 21:06:01 EDT
Thanks guys.  I'd be curious to know how things are now with kernel-2.6.29-21.fc11?  There's some changes in there that may possibly help.
Comment 11 Parag Warudkar 2009-04-12 13:19:31 EDT
F11 snapshot live cd works OK my 8600M GT Macbook Pro, the test day Live CD did not - please test.
Comment 12 Ben Skeggs 2009-04-12 22:16:09 EDT
(In reply to comment #11)
> F11 snapshot live cd works OK my 8600M GT Macbook Pro, the test day Live CD did
> not - please test.  
Sweet, I'd say this issue is likely resolved then.  Though, I'll wait to hear from the reporter before closing.  Thanks!
Comment 13 Stewart Adam 2009-04-12 23:50:05 EDT
I'll try to test this on Wednesday and let you know how it goes.
Comment 14 Jared Smith 2009-04-15 11:52:22 EDT
The kernel/xorg drivers in F11 snapshot 1 LiveCD work great with nouveau.modeset=1 set on  the kernel command-line. 

A big hats off to all who helped get this fixed!
Comment 15 Ben Skeggs 2009-04-15 20:27:21 EDT
Excellent, thanks!
Comment 16 Stewart Adam 2009-04-15 21:44:03 EDT
Yup, works here to with the UEFI test day live image. Thanks for the quick fix!

Note You need to log in before you can comment on or make changes to this bug.