Bug 492247 - Update of the "How do I upgrade my Red Hat Network (RHN) Proxy to the latest version?" KB article.
Update of the "How do I upgrade my Red Hat Network (RHN) Proxy to the latest ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Miroslav Suchý
Jan Pazdziora
http://kbase.redhat.com/faq/docs/DOC-...
:
Depends On:
Blocks: 456984 456999
  Show dependency treegraph
 
Reported: 2009-03-26 00:00 EDT by Brandon Perkins
Modified: 2009-09-10 10:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:38:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brandon Perkins 2009-03-26 00:00:41 EDT
Description of problem:
Update of the "How do I upgrade my Red Hat Network (RHN) Proxy to the latest version?" KB article.

Version-Release number of selected component (if applicable):
5.3.0

How reproducible:
Always.

Steps to Reproduce:
1. Read http://kbase.redhat.com/faq/docs/DOC-10806 for current accuracy.
  
Actual results:
A little behind the times according to Support.

Expected results:
Should be fully accurate to both Development and QA.

Additional info:
Comment 1 Miroslav Suchý 2009-06-05 10:51:45 EDT
The draft is in https://bugzilla.redhat.com/show_bug.cgi?id=492248#c1
with cliff comments in https://bugzilla.redhat.com/show_bug.cgi?id=492248#c2
Comment 2 Miroslav Suchý 2009-06-18 08:12:34 EDT
First you will need to log in to:
 https://kbase.redhat.com/faq/login.jspa
Using your kerberos login and password (I know, I know...)

Updated article:
How do I upgrade my Red Hat Network (RHN) Proxy to the latest version using reprovision?
http://kbase.redhat.com/faq/docs/DOC-10805
which is edited and update version of original article:
How do I upgrade my Red Hat Network (RHN) Proxy to the latest version?
http://kbase.redhat.com/faq/docs/DOC-10806

And following articles are brand new:

How do I upgrade my RHN Proxy to latest version?
http://kbase.redhat.com/faq/docs/DOC-17354

How do I upgrade my RHN Proxy to latest version using WebUI installer?
http://kbase.redhat.com/faq/docs/DOC-17353

How do I upgrade my RHN Proxy to latest version using Command Line Installer?
http://kbase.redhat.com/faq/docs/DOC-17352
Comment 4 Jan Pazdziora 2009-06-30 07:59:03 EDT
http://kbase.redhat.com/faq/docs/DOC-17354:

There is -> There are.

way -> ways.

I don't like the fact that with the first link you say when to use that option, and with the other two you say what they do. That should be consistent.

for all version -> for all versions.

http://kbase.redhat.com/faq/docs/DOC-10805

The process of upgrading a Red Hat Network (RHN) Proxy Server in the simplest terms an upgrade is as such: -- cannot parse that sentence.

Preparation -- why is that one bold?

The title of that article is How do I upgrade my Red Hat Network (RHN) Proxy to the latest version using reprovision? and step 2 is Reprovision that server to either Red Hat Enterprise Linux AS 3 or 4 or Red Hat Enterprise Linux 5 Server. That does not sound correct -- the latest version of RHN Proxy when these articles will go live will be 5.3, and that is not supported on RHEL AS 3. Even if we wanted to make it live now, still the latest is RHN Proxy 5.2, not available on RHEL AS 3.

RHN Proxy Installation Guide . -- space before period.

For newer RHN Proxy is recommended Red Hat Enterprise Linux 5 Server. -> For newer RHN Proxy version, Red Hat Enterprise Linux 5 Server is recommended. But I wonder why we talk about RHN Proxy 4.x, 5.0 and 5.1 here at all -- this article is about upgrade to latest RHN Proxy, and it that version which we should promote.

via it's top-level parent -> via its top-level parent.

For RHN Proxy 5.2 and older -- again, we should not talk about versions < 5.3 at all.

While upgrading an RHN Proxy Server which is configured as a Monitoring Scout, be aware that any probes configured against this Scout will be lost during the upgrade process. -- the document should say what to do in that situation. Will scout push work and fix the problem? Or?

see the RHN Reference Guide .  -- space before period.

Re-install the operating system on the machines in question will be needed. -- Either Reinstall *of* or just drop that *will be needed*.

go to "Install RHN Proxy" -- missing period.

Does the file name rhn-org-httpd-ssl-archive--1.0-RELEASE.tar really have two dashes?

or via it's top-level -> its.

Is it OK that all documentation links lead to http://www.redhat.com/docs/manuals/satellite/ and not to the documents the link talks about?

http://kbase.redhat.com/faq/docs/DOC-17353

on your RHN Satellite . -- space before period.

Line breaks after Click on, RHN Satellite web, and conflicting packages.

Numbering is 1, 1, 2, 1, 2, which is kinda odd.

No periods after the first three items, while there are periods after the last two.

http://kbase.redhat.com/faq/docs/DOC-17352

No periods after Fully backup you RHN Proxy and Install package spacewalk-proxy-installer.

It would also be good if the articles were proof-read by an English native speaker.
Comment 5 Miroslav Suchý 2009-06-30 09:53:32 EDT
Fixed.
I removed statement about upgrade to "latest version" since this articles are perfectly valid for upgrade from any supported version to any higher supported version.

> Is it OK that all documentation links lead to
> http://www.redhat.com/docs/manuals/satellite/ and not to the documents the link
> talks about?
We discussed this on mailing list. There is no way to link to latest version. In the sense - latest forever. And history prove that we forgot to update documentation so I choosed to point to page where is latest version available.

>It would also be good if the articles were proof-read by an English native
>speaker.
Kbase librarian will review it before it will go live.
Comment 6 Jan Pazdziora 2009-06-30 10:08:40 EDT
Thanks.

http://kbase.redhat.com/faq/docs/DOC-10805:

Numbering is 1, 2, 1, 2, 3, 4, 1. I assume that the newline after that "For" is the problem, and something similar for the last 1.

Similar issue in the Restore custom package repository section, numbering is 1, 1.

http://kbase.redhat.com/faq/docs/DOC-17352:

The last number in the Upgrade section should probably be 6, not 1.
Comment 7 Miroslav Suchý 2009-07-01 10:02:30 EDT
Fixed. And hopefully the numbering will not break in meantime.
Comment 8 Jan Pazdziora 2009-07-01 10:28:37 EDT
Numbering is OK now. Marking as VERIFIED.
Comment 9 John Sefler 2009-08-07 13:11:00 EDT
Verified that the updates above have been addressed and are currently published on the knowledge database...

http://kbase.redhat.com/faq/docs/DOC-17354
How do I upgrade my RHN Proxy?
VERSION 3
Created on: Jun 17, 2009 7:45 AM - Current Owner: Miroslav Suchy - Last Modified:  Jun 30, 2009 8:13 AM by Miroslav Suchy 


http://kbase.redhat.com/faq/docs/DOC-10805
How do I upgrade my Red Hat Network (RHN) Proxy using reprovision?
VERSION 11
Created on: Jul 9, 2006 6:00 PM - Current Owner: Miroslav Suchy - Last Modified:  Jul 23, 2009 2:58 PM by Samuel Folk-Williams 


http://kbase.redhat.com/faq/docs/DOC-17353
How do I upgrade my RHN Proxy using WebUI installer?
VERSION 2
Created on: Jun 17, 2009 5:24 AM - Current Owner: Miroslav Suchy - Last Modified:  Jun 30, 2009 9:45 AM by Miroslav Suchy 


http://kbase.redhat.com/faq/docs/DOC-17352
How do I upgrade my Red Hat Network (RHN) Proxy server using the Command Line Installer?
VERSION 6
Created on: Jun 17, 2009 4:59 AM - Current Owner: Miroslav Suchy - Last Modified:  Jul 16, 2009 2:30 AM by Xixi D'Moon 

moving to RELEASE_PENDING
Comment 10 Brandon Perkins 2009-09-10 10:38:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.