Bug 492253 - No crash info with kmail
No crash info with kmail
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 01:17 EDT by Arthur Pemberton
Modified: 2009-07-14 14:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 14:23:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 188135 None None None Never

  None (edit)
Description Arthur Pemberton 2009-03-26 01:17:56 EDT
Description of problem:
When KMail crashes, it give no useful information that I can report.

Version-Release number of selected component (if applicable):
kdepim-3.5.10-2.fc9

How reproducible:
Every crash

Steps to Reproduce:
1. Do something that crashes kmail
  
Actual results:
Window just disappears

Expected results:
Useful output thrown on Konsole, or KCrash report

Additional info:
I have the kdepim debug symbols installed
Comment 1 Kevin Kofler 2009-03-26 20:11:04 EDT
Do you have the KDE 4 kdebase-runtime installed on that machine? Our kdelibs3 is patched to use drkonqi from it.
Comment 2 Kevin Kofler 2009-03-26 20:30:02 EDT
Now, this is a fun bug.

I tried reproducing this with:
kdepim-3.5.10-3.fc9.i386
kdelibs3-3.5.10-3.fc9.i386
kdebase-runtime-4.2.1-2.fc9.i386

What I did:
1. Install kdepim-debuginfo.
2. Run KMail.
3. Simulate a crash with: killall -SIGSEGV kmail

Then I repeated only steps 2 and 3 multiple times, running KMail either from a Konsole with "kmail &" or from the menu. Interestingly, when I run KMail from a Konsole, I get the KDE 4 drkonqi popping up with valid backtraces including debugging symbols for kdepim. When I run it from the menu, it just vanishes. The apparent consistency might just be an accident, as for you it also doesn't work when run from a Konsole.
Comment 3 Kevin Kofler 2009-03-27 04:28:01 EDT
Canceling needinfo, see the reporter's reply on the upstream bug.
Comment 4 Arthur Pemberton 2009-05-04 02:32:05 EDT
Closing this bug here as these problems are no longer reproducible.
Comment 5 Kevin Kofler 2009-05-08 12:39:55 EDT
Still reproducible here, just killall -SIGABRT kmail.
Comment 6 Kevin Kofler 2009-05-08 12:42:14 EDT
Also note that this might not be specific to KDE 3 apps at all, it has also been seen with Amarok 2.0.
Comment 7 Bug Zapper 2009-06-09 23:38:39 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Arthur Pemberton 2009-06-22 00:18:45 EDT
What should we  do about this bug? I'm moving to F11 soon, and no longer have this specific problem in F10
Comment 9 Kevin Kofler 2009-06-22 01:47:24 EDT
I still see this happening with the KDE 3 KMail on F9. I'll see if I can reproduce the problem with the current KDE 4 Amarok, though I'm not sure it's the same bug. I'll also try to send some signals to the KDE 4 KMail on F10 or F11 and see if I can get it to vanish with no crash report.
Comment 10 Bug Zapper 2009-07-14 14:23:53 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.