Bug 492271 - X freezes with nouveau driver from Fedora Test Day
X freezes with nouveau driver from Fedora Test Day
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 05:54 EDT by Török Edwin
Modified: 2009-04-17 06:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 06:23:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (55.62 KB, text/plain)
2009-03-26 05:54 EDT, Török Edwin
no flags Details
/var/log/messages (106.17 KB, text/plain)
2009-03-26 05:54 EDT, Török Edwin
no flags Details
lspci -v (11.99 KB, application/octet-stream)
2009-03-26 06:01 EDT, Török Edwin
no flags Details

  None (edit)
Description Török Edwin 2009-03-26 05:54:00 EDT
Created attachment 336769 [details]
dmesg

Description of problem:
After logging in to X, and starting an application (firefox, terminal), or sometimes even at the login screen everything on the desktop freezes (even the mouse cursor animation). I can still move the mouse, but nothing responds, and switching terminals with ctrl+f1, or killing X with ctrl+alt+backspace doesn't work either.

It doesn't seem to matter what I am doing, after being logged in to X for a short while it freezes.

Version-Release number of selected component (if applicable):
I used this LiveCD (booted from a USB disk):
http://jlaska.fedorapeople.org/live/livecd-fedora-testday-nouveau-20090325-x86_64.iso

How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora LiveCD
2. Login to X
3. start an application (firefox, terminal). After about 2 minutes X freezes.
  
Actual results:
X freezes, unusable, killable only via kill -9

Expected results:
X usable, applications working

Additional info:
Since X was unusable, before logging in I switched to a VT, opened a ssh tunnel to my laptop.
Now I was able to kill X when it freezed (via kill -9). The desktop's image was still there though, even after I executed (chvt 5).
So I blindly logged in as liveuser, and typed startx. Few minutes after using X it froze again.

I was watching dmesg and I noticed that right after freezing I get this message:
[drm] PFIFO_DMA_PUSHER - Ch 1

I also noticed this message (earlier):
[drm] Allocating FIFO number 0
DMA-API: debugging out of memory - disabling
[drm] nouveau_fifo_alloc: initialised FIFO 0
Comment 1 Török Edwin 2009-03-26 05:54:36 EDT
Created attachment 336770 [details]
/var/log/messages
Comment 2 Török Edwin 2009-03-26 05:55:35 EDT
Smolt hardware profile:
http://www.smolts.org/client/show/?uuid=pub_6fd6782e-a9f6-4418-a21c-9bdd93ddefcc
Comment 3 Török Edwin 2009-03-26 06:01:29 EDT
Created attachment 336772 [details]
lspci -v
Comment 4 Ben Skeggs 2009-04-17 03:07:41 EDT
Can you update to libdrm-2.4.6-6.fc11 and xorg-x11-drv-nouveau-0.0.12-29.20090417gitfa2f111.fc11 and retry?

Thanks.
Comment 5 Török Edwin 2009-04-17 06:15:17 EDT
(In reply to comment #4)
> Can you update to libdrm-2.4.6-6.fc11 and
> xorg-x11-drv-nouveau-0.0.12-29.20090417gitfa2f111.fc11 and retry?
> 

With the above 2 packages downloaded from koji.fedoraproject.org, and using the Fedora 11 snapshot 1 LiveCD, nouveau works!
I can login, run firefox, play video, etc. without freezing/crashing.
Nice job! You can close this bug.

The only problem I encountered is that totem playback fullscreen toggling causes slowdowns: https://bugzilla.redhat.com/show_bug.cgi?id=496213

Note that using the versions on the Fedora 11 snapshot1 LiveCD, the display freezes even before the login dialog is shown.

Note You need to log in before you can comment on or make changes to this bug.