Bug 49229 - Background redraw slow
Background redraw slow
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-17 02:04 EDT by Stephen Rasku
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-22 17:56:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My XF86Config-4 file (2.62 KB, text/plain)
2001-07-17 02:05 EDT, Stephen Rasku
no flags Details

  None (edit)
Description Stephen Rasku 2001-07-17 02:04:25 EDT
Description of Problem:

When I switch virtual windows in KDE it takes about 2 seconds for the
background graphic to change.  I don't remember it being that slow before I
upgraded.

How Reproducible:

100%

Steps to Reproduce:
1.  Setup KDE to have different background graphics on each virtual
desktop.
2.  Switch to another virtual desktop.
3.  Wait 2 seconds for background to update.

Expected Results:

Background should update almost instantaneously.
Comment 1 Stephen Rasku 2001-07-17 02:05:23 EDT
Created attachment 23787 [details]
My XF86Config-4 file
Comment 2 Stephen Rasku 2001-07-17 02:06:12 EDT
BTW, I am running XFree86-4.1.0-0.8.6.
Comment 3 Mike A. Harris 2001-07-22 17:56:26 EDT
I do see a bit of a slowdown with VC switching on the Radeon driver.
Perhaps something performance enhancing is disabled by default now..
Not sure, but I'll look into it.
Comment 4 Mike A. Harris 2002-01-25 02:48:31 EST
The VT switching code for Radeon has an intentional delay placed in it
to solve some type of race condition.  It isn't 2 seconds long, but
perhaps there is other reasons it is delayed also.  At any rate, while
a bit annoying to some, it is not a mission critical bug IMHO worthy
of spending any significant amount of time on, since there is no
crashing or display corruption.  It is likely to get fixed upstream
at some point when it anoys someone enough.

Note You need to log in before you can comment on or make changes to this bug.