Bug 4923 - rvplayer realplayer 5.0, can't get it to work in redhat 6.0
Summary: rvplayer realplayer 5.0, can't get it to work in redhat 6.0
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dev
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-05 07:47 UTC by jszabo
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-07 13:50:43 UTC


Attachments (Terms of Use)

Description jszabo 1999-09-05 07:47:47 UTC
rvplayer
realplayer

can't get realplayer 5.0 to work in redhat 6.0 for i386
when I play welcome.rm it says:

General error.  An error has occurred.

For more information, please see Error 1 at:
http://www.realaudio.com/help/errors

but error 1 is the most general of errors

it does say this at the unix prompt:

'****audio: write error: 33 bytes errno: 0'

but /dev/dsp & /dev/mixer are writeable
I can send an strace if you want

I am using the linux ELF version of rvplayer 5.0
had to copy all the rvplayer *.so files to /usr/lib to make
any progress at all

Comment 1 Bill Nottingham 1999-09-07 13:50:59 UTC
There are two problems. First of all, it's relying on a bug
that was present in the sound drivers in the 2.0 kernels that's
been fixed in the 2.2 kernel. There are various fixes for this,
most involve patching the realplayer binary, or an LD_PRELOADED
library. (Search on the web for 'rpopen'.) Also, the RealPlayer
has some incompatibilites with glibc-2.1.

Your best bet is to download the G2 beta from Real's site.


Note You need to log in before you can comment on or make changes to this bug.