This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 492319 - Evolution crashes when launched for the first time
Evolution crashes when launched for the first time
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution-rspam (Show other bugs)
10
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Lucian Langa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 09:10 EDT by Nik Lam
Modified: 2009-04-22 16:28 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.0.6-5.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 16:27:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash dump (7.75 KB, text/plain)
2009-03-26 09:10 EDT, Nik Lam
no flags Details
crash dump after evolution-rspam-debuginfo installed (8.17 KB, text/plain)
2009-03-26 11:08 EDT, Nik Lam
no flags Details
crash dump after evolution-rspam-debuginfo installed using debuginfo-install command (8.61 KB, text/plain)
2009-03-26 11:21 EDT, Nik Lam
no flags Details

  None (edit)
Description Nik Lam 2009-03-26 09:10:58 EDT
Created attachment 336794 [details]
crash dump

Description of problem:

In a brand new account on the system, with no ~/.gnome or ~/.evolution directories, when evolution is launches, it crashes.

Version-Release number of selected component (if applicable):
evolution-2.24.5-1.fc10 

How reproducible:
Always.

Steps to Reproduce:
1. Create new account on system
2. Log into the account (into gdm)
3. start gnome-terminal
4. type "evolution"
  
Actual results:

=======begin shell output===========
evolution-shell-Message: Killing old version of evolution-data-server...

(evolution:5241): evolution-smime-WARNING **: initializing security library without cert databases.
(evolution:5241): e-data-server-DEBUG: Loaded default categories
addressbook_migrate (0.0.0)
Rspam Plugin enabled

=======end shell output===========

Evolution then crashes and bug-buddy is launched.

Expected results:

Evolution should launch the first-time setup wizard.

Additional info:

See gnome bugbuddy report http://bugzilla.gnome.org/show_bug.cgi?id=576667

The problem does not occur on an account which already has an established evolution profile.
Comment 1 Matthew Barnes 2009-03-26 10:18:51 EDT
Crash appears to be originating from the evolution-rspam plugin.
Comment 2 Lucian Langa 2009-03-26 10:50:15 EDT
Nik,
is it possible you could provide a crash report with evolution-rspam-debuginfo installed. Use debuginfo-install to install evolution-rspam.
Thank you.
Comment 3 Nik Lam 2009-03-26 11:08:55 EDT
Created attachment 336822 [details]
crash dump after evolution-rspam-debuginfo installed
Comment 4 Nik Lam 2009-03-26 11:21:03 EDT
Created attachment 336826 [details]
crash dump after evolution-rspam-debuginfo installed using debuginfo-install command

I re-read Lucian's instructions, which requested using debuginfo-install, instead of what I did which was to just yum install the debuginfo package manually.

I've removed the package using yum, then used debuginfo-install to install it. This time it downloaded and installed glibc-debuginfo-2.9-3 as well, so I created this new crashdump.

The dump still seems to be generated by evolution itself though.
Comment 5 Lucian Langa 2009-03-26 11:27:03 EDT
yes but now it contains evolution-rspam symbols.
dumps are ok now.
thank you.
Comment 6 Fedora Update System 2009-04-06 01:40:44 EDT
evolution-rspam-0.0.6-5.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/evolution-rspam-0.0.6-5.fc10
Comment 7 Fedora Update System 2009-04-06 01:42:08 EDT
evolution-rspam-0.0.6-4.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/evolution-rspam-0.0.6-4.fc9
Comment 8 Fedora Update System 2009-04-06 16:26:34 EDT
evolution-rspam-0.0.6-5.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update evolution-rspam'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3330
Comment 9 Fedora Update System 2009-04-06 16:28:44 EDT
evolution-rspam-0.0.6-4.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update evolution-rspam'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-3341
Comment 10 Fedora Update System 2009-04-22 16:27:08 EDT
evolution-rspam-0.0.6-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-04-22 16:28:39 EDT
evolution-rspam-0.0.6-5.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.