Bug 49232 - updated elm defaults to emacs as editor previous was vi
updated elm defaults to emacs as editor previous was vi
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: elm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-17 05:05 EDT by Henri Schlereth
Modified: 2015-01-07 18:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-17 11:39:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri Schlereth 2001-07-17 05:05:11 EDT
Description of Problem:
previous versions of elm used vi.

How Reproducible:
Not have emacs installed and try to reply to an email. Will not be able to
edit.
Comment 1 Trond Eivind Glomsrxd 2001-07-17 10:17:00 EDT
Hmmmm... detected when creating the config file, as I obviously have it
installed. Oh well... just specify the editor in your config file or set EDITOR.
Or install emacs, of course :)
Comment 2 Glen Foster 2001-07-17 11:39:27 EDT
I'm re-opening this defect (a) at the request of the submitter, and (b) because
I agree that changing the default editor without adequate justification is a
defect.  If it is determined that the upstream maintainer of elm changed this,
then this defect can be closed (again).  But if this is a typo (or a thinko),
the original "default behavior" must be re-instated.
Comment 3 Trond Eivind Glomsrxd 2001-07-17 12:16:47 EDT
What happened is that elm picks up the default editor (EDITOR) on your system
when configuring... which is emacs on my system. This is just the default pick,
and should be overriden with your EDITOR variable or config file. 

While not a bug, it is a change in behaviour which it will be hardcoded not to
to do in future releases.

2.5.5-3 is back to vi as default (which looks like a natural match for elm).
Comment 4 Henri Schlereth 2001-07-17 12:48:22 EDT
Flame wars aside (emacs vs. vi) . The mystery question is why did it default to
emacs when
emacs is not installed? It should have picked vi then, shouldnt it? Since this
is a
vanilla 7.1 plus patches where is the default EDITOR set? In the environmental 
variables or in elmrc or $HOME/.elm/elmrc?
Comment 5 Trond Eivind Glomsrxd 2001-07-17 13:42:18 EDT
It will use the EDITOR variable anytime, but the default is only detected during
the configure phase.

Note You need to log in before you can comment on or make changes to this bug.