Bug 492333 - X doesn't start with nouveau - QA test day
X doesn't start with nouveau - QA test day
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
i686 Linux
high Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 10:34 EDT by John Armitage
Modified: 2009-04-02 07:54 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 04:44:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log using the nouveau driver (10.64 KB, application/octet-stream)
2009-03-26 10:34 EDT, John Armitage
no flags Details
startx trace of nVidia Corporation GeForce 7050/nForce 610i (rev a2) (1.70 KB, text/plain)
2009-04-02 03:01 EDT, Brian C. Lane
no flags Details

  None (edit)
Description John Armitage 2009-03-26 10:34:34 EDT
Created attachment 336815 [details]
Xorg.0.log using the nouveau driver

X fails to start with nouveau driver on GeForce 7050, using the livecd from https://fedoraproject.org/wiki/QA/Test_Days/2009-03-26

Hardware Profile
http://www.smolts.org/client/show/pub_55eefe30-c930-4b16-9584-456edf358d99
Comment 1 Adam Williamson 2009-03-26 14:34:50 EDT
To prevent confusion - the attachment is in fact Xorg.0.log , not xorg.conf , so that's what we want.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Ben Skeggs 2009-03-29 22:07:44 EDT
Hello, thanks for the report!  Can you install the RPM available at http://koji.fedoraproject.org/scratch/bskeggs/task_1264803/ and see how you go with that?

Also, you're card is not currently supported with any form of acceleration in nouveau.  We'll need a trace of the binary driver initialising the card to be able to change that.  If you get a spare moment, http://nouveau.freedesktop.org/wiki/MmioTrace would be useful!
Comment 3 Adam Williamson 2009-03-30 15:46:08 EDT
setting needinfo, as Ben asked for some info.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Brian C. Lane 2009-04-02 03:00:27 EDT
I installed the rpm from the link above (using --force to override the newer on from the liveCD). X now starts up with a startx.

I traced running startx using these instructions:

$ mount -t debugfs debugfs /debug
$ echo mmiotrace > /debug/tracing/current_tracer
$ cat /debug/tracing/trace_pipe > mydump.txt &
Start X or whatever.
$ echo "X is up" > /debug/tracing/trace_marker
$ echo nop > /debug/tracing/current_tracer

attachment is xtrace.txt
Comment 5 Brian C. Lane 2009-04-02 03:01:42 EDT
Created attachment 337726 [details]
startx trace of nVidia Corporation GeForce 7050/nForce 610i (rev a2)
Comment 6 Ben Skeggs 2009-04-02 04:44:08 EDT
Thanks for testing the RPM, I'll mark this bug as resolves since things now work for you.

As for the trace, that'll still be needed for us to do acceleration on your card.  For that, you'll need to install the NVIDIA binary driver however and trace that, rather than nouveau.  The instructions you listed are mostly correct, however, it's important that you load NVIDIA's kernel module after the "echo mmiotrace > /debug/tracing/current_tracer" :)

Thanks!
Ben.
Comment 7 John Armitage 2009-04-02 07:54:27 EDT
FYI this was my bug however using the rpm from the link does enable me to startx and I am working on the mmiotrace.

Note You need to log in before you can comment on or make changes to this bug.