Bug 492335 - josm doesn't run with latest java-1.6.0-openjdk update
josm doesn't run with latest java-1.6.0-openjdk update
Status: CLOSED DUPLICATE of bug 492018
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 10:39 EDT by Ben Konrath
Modified: 2015-11-25 12:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 11:50:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Konrath 2009-03-26 10:39:14 EDT
Description of problem:

josm doesn't run with latest java-1.6.0-openjdk update. It worked fine with the previous version of java-1.6.0-openjdk.

Version-Release number of selected component (if applicable):

% rpm -qa | grep openjdk
java-1.6.0-openjdk-devel-1.6.0.0-11.b14.fc10.i386
java-1.6.0-openjdk-1.6.0.0-11.b14.fc10.i386
java-1.6.0-openjdk-plugin-1.6.0.0-11.b14.fc10.i386

How reproducible:

Always

Steps to Reproduce:
1. wget http://josm.openstreetmap.de/josm-tested.jar
2. java -jar josm-tested.jar
  
Actual results:

The GUI freezes before the application is fully loaded.

Expected results:

The application should start and run as it did with the previous version of java-1.6.0-openjdk.
Comment 1 Omair Majid 2009-03-26 11:10:29 EDT
Using java-1.6.0-openjdk-1.6.0.0-11.b14.fc10.i386, josm works for me. Do you have input methods enabled? If so, it could be bug 492018.
Comment 2 Ben Konrath 2009-03-26 11:50:10 EDT
Yep, it seems to be bug 492018, marking as duplicate. Thanks.

*** This bug has been marked as a duplicate of bug 492018 ***
Comment 3 LeoChen_ca 2015-11-24 22:03:50 EST
What's the solution? Thanks.
Comment 4 Deepak Bhole 2015-11-25 12:06:06 EST
(In reply to LeoChen_ca from comment #3)
> What's the solution? Thanks.

Hi, this bug was opened against Fedora 10, which has been unsupported for a very long time. OpenJDK6 is no longer supported in Fedora either, only OpenJDK8 is. Please use josm with OpenJDK8 and let us know if there are any issues.

Note You need to log in before you can comment on or make changes to this bug.