Bug 492344 - KMS boot fails to set correct resolution.
KMS boot fails to set correct resolution.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 11:05 EDT by Alex Hudson (Fedora Address)
Modified: 2009-09-09 09:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 09:36:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.log with modesetting turned on. (50.84 KB, text/plain)
2009-03-26 11:05 EDT, Alex Hudson (Fedora Address)
no flags Details
Xorg.log without modesetting turned on (42.53 KB, text/plain)
2009-03-26 11:47 EDT, Alex Hudson (Fedora Address)
no flags Details
/var/log/messages from the boot that wedged with modesetting on (75.47 KB, application/octet-stream)
2009-03-31 05:32 EDT, Alex Hudson (Fedora Address)
no flags Details
Xorg.0.log with modesetting on, when system wedges. (14.10 KB, application/octet-stream)
2009-03-31 05:33 EDT, Alex Hudson (Fedora Address)
no flags Details

  None (edit)
Description Alex Hudson (Fedora Address) 2009-03-26 11:05:54 EDT
Created attachment 336820 [details]
Xorg.log with modesetting turned on.

Description of problem:

I'm doing the KMS test for QA day. Setting nouveau.modeset=1 on boot brings up Plymouth in what appears to be a reasonable resolution; before gdm comes up the resolution changes though (I get garbage at the bottom of the screen), and getting into X I see that the resolution is only 1024x768.

The resolution should be 1920x1440 (or close, I can't recall ;) and booting without KMS turned on does that correctly.

Interestingly, the Display configuration application shows my LCD panel as "Epson 15inch" when correct, and "Unknown" when not - so presumably part of the problem might be to do with knowing what the panel is capable of.

I've attached my Xorg.0.log from an unsuccessful test with KMS turned on.
Comment 1 Alex Hudson (Fedora Address) 2009-03-26 11:47:45 EDT
Created attachment 336836 [details]
Xorg.log without modesetting turned on
Comment 2 Adam Williamson 2009-03-27 16:39:19 EDT
Looks like it fails to read the EDID in KMS mode for some reason.

Ben, I think the logs should be enough info - yell if not :)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Ben Skeggs 2009-03-30 00:18:50 EDT
Thanks Adam, they should be enough!

Alex, are you able to try the latest build from koji (http://koji.fedoraproject.org/koji/buildinfo?buildID=95819).  I fixed a bug which could be causing the issues you're seeing a couple of days ago.

Thanks,
Ben.
Comment 4 Alex Hudson (Fedora Address) 2009-03-30 04:30:39 EDT
Hi Ben,

Build downloaded and installed - sadly, it makes matters worse! When the "switch" to gdm comes up, my machine now locks up :( The screen goes black - no backlight - and the OS appears to be wedged (e.g., not even capslock working).

If there is a way of debugging this I'm happy to get my hands a bit dirty.
Comment 5 Ben Skeggs 2009-03-30 06:20:26 EDT
Thanks! If you're somehow able to grab the X log from after the lock up, that'd be very useful!  Most of the time the info makes it there, hopefully it does in this case too!  Also, the /var/log/messages from afterwards may reveal something.
Comment 6 Alex Hudson (Fedora Address) 2009-03-31 05:31:59 EDT
Right; I currently have two roots - one F10, one F11, so I booted F11 but grabbed files from F10.

Now, the system wedged pretty thoroughly - to the point that SysRq didn't seem to do anything, but after about a minute (almost exactly) it unwedged somehow. Don't know how or why, but I could then shut the system down and retrieve the files. Hopefully there is something useful in here!

Xorg.log.0 gives me this nugget:

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e99e6]
1: /usr/bin/Xorg(xf86SigHandler+0x6f) [0x47ddef]
2: /lib64/libc.so.6 [0x7f445e3043e0]
3: /usr/bin/Xorg(xf86InitViewport+0x4b) [0x479fdb]
4: /usr/bin/Xorg(InitOutput+0xf1d) [0x46822d]
5: /usr/bin/Xorg(main+0x20c) [0x42cedc]
6: /lib64/libc.so.6(__libc_start_main+0xfd) [0x7f445e2ef6ad]
7: /usr/bin/Xorg [0x42c509]

I'm going to attach the full log and /var/log/messages too though, because I suspect there is some stuff in the lead-up which might help make sense of things.

Cheers!
Comment 7 Alex Hudson (Fedora Address) 2009-03-31 05:32:44 EDT
Created attachment 337284 [details]
/var/log/messages from the boot that wedged with modesetting on
Comment 8 Alex Hudson (Fedora Address) 2009-03-31 05:33:30 EDT
Created attachment 337285 [details]
Xorg.0.log with modesetting on, when system wedges.
Comment 9 Adam Williamson 2009-04-23 16:07:59 EDT
(just a justification: severity is 'low' because modesetting is not enabled by default)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Gianluca Sforna 2009-06-01 11:14:06 EDT
I'm definitely seeing this on my Quadro NVS 130, feel free to ping me if you need any additional info
Comment 11 Adam Williamson 2009-06-01 14:07:14 EDT
issues like this are quite hardware-dependent, probably best to open a separate report with all the usual info (X logs, xorg.conf and so on).
Comment 12 Gianluca Sforna 2009-06-02 18:38:18 EDT
done: bug 503839
Comment 13 Bug Zapper 2009-06-09 08:39:20 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Alex Hudson (Fedora Address) 2009-09-09 07:58:42 EDT
This is verified again for F12 on the Radeon test day.

Now GDM does not appear at all; the screen remains blank and I don't even seem to be able to change VT.
Comment 15 Ben Skeggs 2009-09-09 08:14:30 EDT
After booting to a blank display, can you reboot with "nouveau.modeset=0 3" in your boot options and post /var/log/messages and /var/log/Xorg.0.log.

Thanks.
Comment 16 Alex Hudson (Fedora Address) 2009-09-09 08:26:56 EDT
Sorry; I've commented on the wrong bug here, I meant to open one for Radeon.

Having just tested, KMS boot on this NVidia laptop now works fine in F12. This bug can now be closed!
Comment 17 Ben Skeggs 2009-09-09 09:36:00 EDT
Ahh very good to hear :)  I'll close this then!

Note You need to log in before you can comment on or make changes to this bug.