Bug 492364 - mouse is grabbed even though usb tablet is used
mouse is grabbed even though usb tablet is used
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk-vnc (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 12:17 EDT by Julian Sikorski
Modified: 2009-04-15 14:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.3.8-4.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 14:01:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2009-03-26 12:17:35 EDT
Description of problem:
One of the features of Fedora 11 was making the qemu usb tablet work out of the box so that mouse will no longer have to be grabbed. When Fedora 10 is used as a host, the mouse will be grabbed once, and then after pressing ctrl-alt the tablet will work as advertised.

Version-Release number of selected component (if applicable):
gtk-vnc-0.3.8-2.fc10.x86_64

How reproducible:
always

Steps to Reproduce:
1. install f11 guest, remembering to pass --os-variant=fedora11 parameter
2. wait for anaconda to come up
3. click inside the guest window
  
Actual results:
mouse is grabbed once and then works correctly

Expected results:
mouse works correctly since the beginning

Additional info:
this also happens on consecutive boots of the guest
Comment 1 Daniel Berrange 2009-03-27 07:38:11 EDT
This is a "fun" problem.

What is going on is that during initial bootup of the guest, (eg while plymouth graphical boot is running), the PS/2 mouse is in use. 

Only once GDM login screen starts does the "real" X server activate the USB tablet.

So during initial boot when the PS/2 mouse is in use, the VNC server is running in relative mouse mode, and thus cursor grab will be used by GTK-VNC clients.

Once the USB tablet is activated, the VNC server switches over to absolute mouse mode. GTK-VNC will no longer grab the mouse in this mode, but if you already had the mouse grabbed from when the guest was booting, it won't be released.


We can't avoid the cursor grab during initial bootup phase, but we could consider automatically releasing the mouse grab when changing from relative -> absolute mouse mode.
Comment 2 Julian Sikorski 2009-03-27 14:17:43 EDT
The mouse will also get grabbed if you click inside the guest window for the first time *after* the login screen appears.
Comment 3 Fedora Update System 2009-03-31 16:27:55 EDT
gtk-vnc-0.3.8-4.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtk-vnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3042
Comment 4 Fedora Update System 2009-04-15 14:01:24 EDT
gtk-vnc-0.3.8-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.