Bug 492375 - xorg fails to detect and use nouveau driver with livecd
xorg fails to detect and use nouveau driver with livecd
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 12:44 EDT by Robert M Williams
Modified: 2009-03-26 14:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 14:31:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log from system (41.63 KB, text/plain)
2009-03-26 12:44 EDT, Robert M Williams
no flags Details

  None (edit)
Description Robert M Williams 2009-03-26 12:44:18 EDT
Created attachment 336849 [details]
xorg log from system

Description of problem:
xorg chooses fbdev/vesa as opposed to nouveau for geforce 8200M G video

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.boot live cd
2.
3.
  
Actual results:
super slow performance due to use of fbdev/vesa 

Expected results:
autodetection and use of nouveau driver

Additional info:
smolt profile
http://www.smolts.org/client/show/pub_2056514d-e498-477e-982a-806fc6aca393
Comment 1 Adam Williamson 2009-03-26 12:59:21 EDT
This is actually intentional, viz the patch in xorg-x11-server which enables nouveau by default:

-	case 0x10de: case 0x12d2:   driverList[0] = "nv";	break;
+	case 0x10de:
+	    switch (dev->device_id & 0xfff0) {
+	    /* Non-functional with both nouveau and nv */
+	    case 0x0840:
+	    case 0x0860:
+		driverList[0] = "vesa";
+		break;
+	    default:
+		driverList[0] = "nouveau";
+		break;
+	    }
+	    break;

i.e. the device ids 0x84* and 0x86* are intentionally set to use vesa. This is because they have been reported not to work with nv or nouveau. However, as you report success, this may need some tweaking.

Ben, what do you want to do here? Do we find the people who reported problems with the 84* IDs - http://bugs.freedesktop.org/show_bug.cgi?id=17526 and http://bugs.freedesktop.org/show_bug.cgi?id=18092 are the relevant fd.o reports - and ask them to re-test with the Test Day live CD?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Adam Williamson 2009-03-26 14:31:06 EDT
Correction: Robert never actually said it works with nouveau, sorry Robert. And, indeed, it doesn't - https://bugzilla.redhat.com/show_bug.cgi?id=492368 . So this is not a bug, because we're intentionally defaulting to vesa on these cards because we actually know that nouveau doesn't work :)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.