Bug 492380 - LiveCD TestDay-Nouveau freezes Desktop System (GF7600 GS)
LiveCD TestDay-Nouveau freezes Desktop System (GF7600 GS)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 13:04 EDT by Martin Kho
Modified: 2009-07-01 18:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 18:36:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fedora 10: dmesg (34.46 KB, application/octet-stream)
2009-03-26 20:36 EDT, Martin Kho
no flags Details
Fedora 10: Xorg.0.log (46.12 KB, application/octet-stream)
2009-03-26 20:37 EDT, Martin Kho
no flags Details
LiveCD: dmesg (38.78 KB, application/octet-stream)
2009-03-26 21:26 EDT, Martin Kho
no flags Details
LiveCD: Xorg.0.log (24.22 KB, application/octet-stream)
2009-03-26 21:27 EDT, Martin Kho
no flags Details
Xorg.0.log from i686 iso, succes (39.71 KB, application/octet-stream)
2009-05-18 16:55 EDT, Martin Kho
no flags Details
dmesg from i686 iso, succes (39.93 KB, application/octet-stream)
2009-05-18 16:56 EDT, Martin Kho
no flags Details
Xorg.0.log from x86_64 preview, fail (24.35 KB, application/octet-stream)
2009-05-18 16:57 EDT, Martin Kho
no flags Details
dmesg from x86_64 preview, fail (38.38 KB, application/octet-stream)
2009-05-18 16:58 EDT, Martin Kho
no flags Details

  None (edit)
Description Martin Kho 2009-03-26 13:04:02 EDT
Description of problem:

Tried running "livecd-fedora-testday-nouveau-20090325-x86_64", but got stuck when X was trying to start. My system was completely unresponsive.

My NVIDIA-card: 01:00.0 VGA compatible controller [0300]: nVidia Corporation G70 [GeForce 7600 GS] [10de:0392] (rev a1)

My hardware description can be found at:

http://www.smolts.org/show?uuid=pub_114ecdbe-24f8-4421-9d76-eabbc46cfcab


How reproducible:


Steps to Reproduce:
1. Boot from USB or CD-Rom
2. Just wait till X tries to start
3. ... Hit Reset button
  
Actual results:
Complete unresponsive system

Expected results:
Normal start of X

Additional info:
Comment 1 Martin Kho 2009-03-26 17:13:54 EDT
On my regular system (Fedora 10 with latest updates) and Nouveau driver from package: xorg-x11-drv-nouveau-0.0.11-1.20090106git133c1a5.fc10.x86_64 everything runs OK.

Is it interesting to run the tests in this configuration?

Thanks,

Martin Kho
Comment 2 Ben Skeggs 2009-03-26 19:03:32 EDT
Thanks!  I'd be interested in /var/log/Xorg.0.log and the output of running "dmesg" after trying to start X with nouveau from both your F10 and LiveCD configurations.
Comment 3 Martin Kho 2009-03-26 20:36:24 EDT
Created attachment 336931 [details]
Fedora 10: dmesg
Comment 4 Martin Kho 2009-03-26 20:37:32 EDT
Created attachment 336932 [details]
Fedora 10: Xorg.0.log
Comment 5 Martin Kho 2009-03-26 20:44:38 EDT
I tried to get into the LiveCD version, but failed. So I could not get a dmesg and Xorg log. Is there a kernel parameter I can use to get to the console (rulevel 3) instead of X (runlevel 5)? I've tried to interrupt the boot process by pressing I, without succes. 

Thanks,

Martin
Comment 6 Ben Skeggs 2009-03-26 20:56:31 EDT
Yup, there sure is.  Just append "3" to the kernel commandline and it'll boot right into runlevel 3
Comment 7 Martin Kho 2009-03-26 21:26:47 EDT
Created attachment 336935 [details]
LiveCD: dmesg
Comment 8 Martin Kho 2009-03-26 21:27:26 EDT
Created attachment 336936 [details]
LiveCD: Xorg.0.log
Comment 9 Martin Kho 2009-03-31 17:49:57 EDT
Hi Ben,

Just installed F11-Beta. The nouveau-driver is working now like a charm. So this bug report can be closed.

Martin Kho
Comment 10 Ben Skeggs 2009-03-31 18:36:56 EDT
Thank you for the update, I'm glad to hear that!  Closing.
Comment 11 Martin Kho 2009-04-02 15:19:50 EDT
Hi Ben,

Sorry for interrupting you, but I was a little bit too optimistic. I first tried F11-Beta KDE-LiveCD. This was a i586 version. No problems with the nouveau-driver. Next I tried a x86_64 net install. This time the nouveau-driver failed. Same error as in the Xorg.0.log file from comment #8. So it seems there is a problem with the driver and my x86_64 architecture. If I can do anything to test, please let me know.

Martin
Comment 12 Martin Kho 2009-04-12 10:36:21 EDT
Hi,

Today I tried F11-Snap1-x86_64-Live-KDE without success. Still the same error: Fatal GPU lockup, /dev/fb0 not found (see #8). So the Nouveau driver, to me, is a real blocker.

Martin
Comment 13 Martin Kho 2009-04-12 10:37:23 EDT
I see this bug is closed. Do I have to reopen it?

Martin
Comment 14 Ben Skeggs 2009-04-12 22:24:56 EDT
I'm thinking this is probably a duplicate of rh#493222 now and not the same bug.  I have an almost identical card (AGP rather than PCIE) to yours here that I can't reproduce the issue on however (which is unfortunate, makes it easier to fix!).
Comment 15 Martin Kho 2009-04-13 05:15:34 EDT
Hi Ben,

Thanks for your response. I doubt if this bug is a duplicate of rh#493222. In their reports - it seems - they had F11-Beta working. After some updates their problems started. F11-Beta x86_64 did never worked for me, but F11-Beta i586 did. My problem was always the same, GPU lockup and /dev/fb0 not found. Maybe you have some tips, so that I can get more information?


Martin
Comment 16 Ben Skeggs 2009-04-13 05:21:31 EDT
That thought occurred to me, when you mentioned you did a net install I wondered if you got the updates immediately upon installation, hence the issues?  I *highly* doubt this is an x86_64 issue, every one of my test machines is x86_64..
Comment 17 Martin Kho 2009-04-13 13:21:56 EDT
I'm not sure. I installed F11-Beta net x86_64 on April 2. On April 3, 4 and 8 the nouveau driver was updated. The current version I have now is: xorg-x11-drv-nouveau-0.0.12-25.20090408gitd8545e6.fc11.x86_64. You said you're having the same video card - GeForce 7600 GS, a AGP-version. Mine is PCIe. Can this be a clue? On my running system - rawhide x86_64 + 'crappy' propriety drivers from NVIDIA - I've "/dev/fb0". Is this device created on the fly?

Martin
Comment 18 Martin Kho 2009-04-13 17:51:40 EDT
Hi,

dmesg in Rawhide shows:

"[drm] Initialized drm 1.1.0 20060810                   
pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
pci 0000:01:00.0: setting latency timer to 64     
nouveau 0000:01:00.0: Detected an NV40 generation card (0x04b200a2)
[drm] Initialized nouveau 0.0.12 20060213 for 0000:01:00.0 on minor 0"

NV40? The NVIDIA driver calls it G73. The same name as given on the nouveau wiki page. NV40 belongs to the 6x series?

So can it be that my video card is wrongly detected?

Info on my card from NVIDIA:

Graphics Processor: GeForce 7600 GS
VBIOS Version: 05.73.22.20.00
Memory: 512 MB
Bus Type: PCI Express 16X
Bus ID: 1:0:0
PCI Device ID: 0x0392
PCI Vendor ID: 0x10de
IRQ: 16

Martin
Comment 19 Ben Skeggs 2009-04-13 21:17:06 EDT
Your card is detected correctly.  G7x is marketing, the card is reporting itself as being NV4B precisely (this is the case for all GeForce 7 cards btw).  From a driver perspective GeForce 7 is almost identical to GeForce 6.
Comment 20 Martin Kho 2009-04-14 07:11:44 EDT
Thanks, Ben, for your information. A little bit confusing isn't it? If you have any other ideas I can try, please let me know.

Martin.
Comment 21 Martin Kho 2009-04-29 14:59:06 EDT
Hi,

fyi, tried today F11-preview-live-kde.x68_64. Again without success. Still the same error: GPU lockup.


Martin
Comment 22 Martin Kho 2009-05-18 12:15:02 EDT
Hi Ben,

Great news ... for you! There seems to be no problem with the nouveau driver. It looks like it has something to do with Plymouth. I had problems 'burning' the x86_64 iso to my usb stick with Fedora's LiveUsb-creator. So I used Unetbootin. This app installs it's own bootloader. Booting the usb-stick went as aspected, X - with nouveau driver - started normal as I had experienced with the x86 iso.

The nouveau driver is working very well, congratulations!

Now I've to see if the Plymouth developers/maintainers can help me further. Maybe that you have any suggestions?

Thanks again for your patient help,

Martin

P.S. Can there be a mode switching problem?
Comment 23 Martin Kho 2009-05-18 16:53:42 EDT
Hi Ben,

Damn ... ;-( I was hit by an old 32bit F11-beta KDE Live x86_64 version, again like what happened in command #9, sorry. See this post from Jesse Keating:

http://fcp.surfsite.org/modules/newbb/viewtopic.php?topic_id=69796&forum=13

I tried the latest F11 preview 'burned' with Unetbootin. X failed to start. I've saved some Xorg.0.logs and dmesg's after the lock up as you've asked.

Thanks,

Martin
Comment 24 Martin Kho 2009-05-18 16:55:20 EDT
Created attachment 344523 [details]
Xorg.0.log from i686 iso, succes
Comment 25 Martin Kho 2009-05-18 16:56:12 EDT
Created attachment 344524 [details]
dmesg from i686 iso, succes
Comment 26 Martin Kho 2009-05-18 16:57:23 EDT
Created attachment 344525 [details]
Xorg.0.log from x86_64 preview, fail
Comment 27 Martin Kho 2009-05-18 16:58:01 EDT
Created attachment 344526 [details]
dmesg from x86_64 preview, fail
Comment 28 Martin Kho 2009-05-19 17:37:18 EDT
Hi Ben,

Today I did some more - systematic - tests. The results are as follows:

F11-Beta-i686-Live-KDE.iso
xorg-x11-drv-nouveau-0.0.12-10.20090310git8f9a580.fc11.i586
Result: driver works

F11-Beta-x86_64-Live-KDE.iso
xorg-x11-drv-nouveau-0.0.12-10.20090310git8f9a580.fc11.x86_64
Result: driver works

Fedora-11-Beta-x86_64-netinst.iso
(couldn't get the rpm name)
nouveau_drv.so: april 3 2009
Result: driver fails

F11-Preview-i686-Live-KDE.iso
xorg-x11-drv-nouveau-0.0.12-31.20090421git47bb00f.fc11.i586
Result: driver fails

F11-Preview-x86_64-Live-KDE.iso
xorg-x11-drv-nouveau-0.0.12-31.20090421git47bb00f.fc11.x86_64
Result: driver fails

Update to latest driver from Rawhide
xorg-x11-drv-nouveau-0.0.12-36.20090514git9656762.fc11.x86_64
Result: driver fails

1. There is no difference between i686 and x86_64. So this seems, as you already have said, not the cause for the problem.

2. In dmesg logs I saw:
[drm] Detected an NV40 generation card (0x04b200a2)
result: driver works

nouveau 0000:01:00.0: Detected an NV40 generation card (0x04b200a2)
Result: driver fails

I hoop this can shed some new light on the case.

Martin

PS. If you need the log files, please let me know.
Comment 29 Martin Kho 2009-07-01 18:44:45 EDT
Hi Ben,

I'm running/testing Rawhide now and guess ... with the nouveau driver. It works! Great. I like to see open source progress :-)

Thanks again,

Martin

P.S. If I have to test something more, please let me know.

Note You need to log in before you can comment on or make changes to this bug.