Bug 492435 - Please split documentation into ppl-doc subpackage
Please split documentation into ppl-doc subpackage
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ppl (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Roberto Bagnara
Fedora Extras Quality Assurance
:
Depends On:
Blocks: AstronomyTracker
  Show dependency treegraph
 
Reported: 2009-03-26 16:01 EDT by Lubomir Rintel
Modified: 2009-03-29 13:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-29 13:05:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Rintel 2009-03-26 16:01:04 EDT
Hi,

Package's documentation is over 1 MB (ppl-0.10, 4112 kbytes). Creating a -doc subpackage and moving the documentation files there would save considerable space on the live media.

Thanks in advance!
Comment 1 Roberto Bagnara 2009-03-26 16:40:43 EDT
I am not sure I understand: we already have a ppl-docs package.
Comment 2 Roberto Bagnara 2009-03-26 16:45:14 EDT
One possibility would be to include the ChangeLog in bzip2 format.  But I don't know if this is compatible with Fedora's packaging rules.
Comment 3 Lubomir Rintel 2009-03-26 17:04:30 EDT
4.0K	BUGS
3.7M	ChangeLog
36K	COPYING
20K	CREDITS
72K	gpl.pdf
80K	gpl.ps.gz
36K	gpl.txt
60K	NEWS
48K	README
20K	README.configure
8.0K	TODO

I believe the pdf and ps files could be moved into -docs and probably ChangeLog as well.

Roberto: Bzipped ChangeLog won't help much, since it can't be compressed further. Note that the live media already uses squashfs compression.
Comment 4 Roberto Bagnara 2009-03-29 13:05:20 EDT
Done in ppl-0.10-11.fc11.  Please let me know if this allows you to do what you wanted to do.

Note You need to log in before you can comment on or make changes to this bug.