Bug 492439 - Please split documentation into perl-doc subpackage
Please split documentation into perl-doc subpackage
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: AstronomyTracker
  Show dependency treegraph
 
Reported: 2009-03-26 16:01 EDT by Lubomir Rintel
Modified: 2009-03-27 14:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-27 14:57:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Rintel 2009-03-26 16:01:18 EDT
Hi,

Package's documentation is over 1 MB (perl-5.10.0, 2448 kbytes). Creating a -doc subpackage and moving the documentation files there would save considerable space on the live media.

Thanks in advance!
Comment 1 Marcela Mašláňová 2009-03-27 10:01:00 EDT
In case we should be splitting our packages with bigger doc, then it should be  added into packaging guidelines after discussion on fedora-devel and probably also on FESCO meeting.
Comment 2 Ralf Corsepius 2009-03-27 13:43:46 EDT
FWIW: I am opposed to splitting out the perl-docs.

(In reply to comment #1)
> In case we should be splitting our packages with bigger doc, then it should be 
> added into packaging guidelines after discussion on fedora-devel and probably
> also on FESCO meeting.  

w/ my FPC-member-hat on:

* The current rule can be summarized as "put all documentation into the package containing the components a document is documenting".
Wrt. this rule, the perl package has deficiencies. Whether addressing them makes sense/is worth it, is a separate problem (IMO, it's not worth it).

* The FPG's recommendation to split out larger docs into separate *-doc packages originates from  packaging "optional docs", e.g. html formated docs.
AFAIS, the current perl package (I only checked FC10) doesn't contain such documents.

* Adding a separate *-doc package for perl adds further packages deps, which further complicates the already complex packaging of perl.

* Technically, separate *-docs packages are not necessary.
Comment 3 Stepan Kasal 2009-03-27 14:57:36 EDT
(In reply to comment #0)
> Package's documentation is over 1 MB (perl-5.10.0, 2448 kbytes). Creating a
> -doc subpackage and moving the documentation files there would save
> considerable space on the live media.

Actually, the documetation files in perl.rpm occupy about 9 MB:
- %{_docdir}/perl-5.10.0/ occupies 2.5 MB
- perl manual pages occupy 6.6 MB

The description of this bug mentiones the former; since it is a compressed version of almost 11 MB of change log text, it should go away.  I moved it to perl-devel, details in bug #492605.

For the latter, I second Ralf's comment #2: --excludedocs is your friend.

According to my private communication with the reporter, the fix for #492605 actually solves his issue; yet I'm setting the resolution to NOTABUG indicating that it is preferable not to split the package.

Note You need to log in before you can comment on or make changes to this bug.