Bug 492461 - Booting with nouveau.modeset=1 fails to start gdm
Booting with nouveau.modeset=1 fails to start gdm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 16:27 EDT by James Laska
Modified: 2013-09-02 02:33 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 18:28:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (137.58 KB, image/jpeg)
2009-03-26 16:27 EDT, James Laska
no flags Details
Rawhide Screenshot (247.29 KB, image/jpeg)
2009-05-04 15:26 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-03-26 16:27:14 EDT
Created attachment 336888 [details]
Screenshot

Description of problem:

While testing the nouveau test day testcase https://fedoraproject.org/wiki/QA:Testcase_nouveau_kms.  On boot up, I see the graphical plymouth startup, but the display hangs and never starts gdm.

Version-Release number of selected component (if applicable):

kernel-2.6.29-0.279.rc8.git6.fc11.x86_64
xorg-x11-drv-nouveau-0.0.12-15.20090323git4067ab4.fc11.x86_64

How reproducible:

everytime

Steps to Reproduce:

1) Download the Test Day live image (https://fedoraproject.org/wiki/QA/Test_Days/2009-03-26#Live_Image)
2) Execute the test - https://fedoraproject.org/wiki/QA:Testcase_nouveau_kms
  
Actual results:

Plymouth boots successfull with the spinfinity plugin, but then the display hangs while transitioning to gdm or finishing up plymouth.  See attached screenshot.  I can ping the system remotely, but am unable to access the consoles for logs.

Expected results:
gdm login prompt

Additional info:
Comment 1 Will Woods 2009-03-26 17:25:11 EDT
I've got a similar lockup; I tried booting into runlevel 3 (with modesetting on), ssh'ing in, and running 'telinit 5; tail -f /var/log/messages /var/log/Xorg.0.log'.

System still hangs, but I've got some error messages:

[drm] i2c and hpd detect differ: 0 vs 1
[drm] i2c and hpd detect differ: 0 vs 1
[drm] i2c and hpd detect differ: 0 vs 1
[drm] i2c and hpd detect differ: 0 vs 1
[drm] Allocating FIFO number 2
[drm] nouveau_fifo_alloc: initialised FIFO 2
[drm:nv50_display_command] *ERROR* timeout: 0x610300 = 0x80010081
[drm:nv50_display_command] *ERROR* timeout: 0x610300 = 0x80010885
[drm:nv50_display_command] *ERROR* timeout: 0x610300 = 0x8001089d
[drm:nv50_display_command] *ERROR* timeout: 0x610300 = 0x80010881
...[etc]

lspci:
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8400 GS (rev a1)

drivers:
kernel-2.6.29-9.fc11.x86_64
xorg-x11-drv-nouveau-0.0.12-16.20090326git01cee29.fc11.x86_64
Comment 2 Walter Francis 2009-03-27 11:02:55 EDT
Sounds similar to what I had happen with the Live CD with my Quadro 2700M nVidia hardware.
Comment 3 Adam Williamson 2009-03-27 16:23:07 EDT
James, Will - in both cases, is this happening only with KMS, and it works fine without KMS?

(Also, Will, for my sanity can you include lspci -nn output - i.e. with the PCI ID - as well? I always go by the PCI ID when searching for duplicates etc. thanks!)

James, you don't seem to have included any information about the hardware.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Williamson 2009-03-27 16:24:14 EDT
from the wiki page, james appears to be reporting this with a Quadro FX 570, Smolt profile http://www.smolts.org/client/show/pub_94e555bc-c513-49a0-b2d8-1f3bc61300ec - James, please confirm (it's good to have this info in the bug as well as the Wiki page...)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Will Woods 2009-03-27 17:24:31 EDT
Yes, this only happens with modeset on - I'm updating this bug from the machine in question.

01:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8400 GS [10de:0422] (rev a1)
Comment 6 Adam Williamson 2009-03-27 17:25:15 EDT
thanks...guess we can assign for now.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 James Laska 2009-03-30 12:19:00 EDT
(In reply to comment #3)
> James, Will - in both cases, is this happening only with KMS, and it works fine
> without KMS?

That is correct
 
> James, you don't seem to have included any information about the hardware.

Does the smolt URL provide sufficient information about the system?

http://www.smolts.org/client/show/pub_94e555bc-c513-49a0-b2d8-1f3bc61300ec
Comment 8 Adam Williamson 2009-03-30 15:55:03 EDT
yep, that should be enough.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Ben Skeggs 2009-05-02 23:04:27 EDT
How do things look here with the latest updates installed?
Comment 10 James Laska 2009-05-04 15:26:20 EDT
Created attachment 342358 [details]
Rawhide Screenshot

I've reinstalled this system to rawhide today (previously F10) and it fails to boot post-install.  The system hangs at the following screen.  I'm not knowledgeable enough to determine the cause of the hang (nouveau, usb, acpi or OTHER).  Any thoughts?
Comment 11 James Laska 2009-05-04 16:05:40 EDT
Retesting with -126 kernel (http://koji.fedoraproject.org/koji/buildinfo?buildID=100756).

The reported issue no longer occurs :)
Comment 12 Ben Skeggs 2009-05-04 18:28:55 EDT
Cool, thanks for testing!

Note You need to log in before you can comment on or make changes to this bug.