Bug 492468 - [nouveau] no graphical boot progress screen display when nouveau.modeset=1 is enabled
[nouveau] no graphical boot progress screen display when nouveau.modeset=1 is...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 17:20 EDT by Niels Haase
Modified: 2009-04-01 18:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-30 15:42:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg of boot (48.12 KB, text/plain)
2009-03-26 17:23 EDT, Niels Haase
no flags Details
dependency problem with plymouth (3.81 KB, text/plain)
2009-03-27 01:03 EDT, Niels Haase
no flags Details

  None (edit)
Description Niels Haase 2009-03-26 17:20:17 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b2) Gecko/20090227 Fedora/3.1-0.7.beta2.fc11 Minefield/3.1b2

try to boot kernel with nouveau.modset=1 enabled. System boots, show up the message: [drm:nv_valid_bios] *ERROR* BIOS signature not found. But it changed the resolution correct and also starts the gdm/gnome without problems.


Reproducible: Always

Steps to Reproduce:
1.enable nouveau.modeset=1 kernel parameter at boot time

Actual Results:  
changed the screen resolution correct, but don't show any graphical boot-screen.

Expected Results:  
correct resolution and graphical boot progress screen

use rawhide with last updates at 2000-03-26
Comment 1 Niels Haase 2009-03-26 17:23:08 EDT
Created attachment 336900 [details]
dmesg of boot

boot messages with show some *ERROR* like

[drm:nv_valid_bios] *ERROR* BIOS signature not found.
[drm] BIT BIOS found
[drm] Display Configuration Block version 4.0 found
[drm] DCB header length 27, with 16 possible entries
[drm] Raw DCB entry 0: 01000323 00010034
[drm] Raw DCB entry 1: 02011300 00000028
[drm] Raw DCB entry 2: 02022386 0f200010
[drm:read_dcb_i2c_entry] *ERROR* DCB I2C table has port type 6
[drm] Raw DCB entry 3: 02022332 00020010
[drm] Raw DCB entry 4: 040333a6 0f200010
[drm:read_dcb_i2c_entry] *ERROR* DCB I2C table has port type 6
[drm] Raw DCB entry 5: 04033312 00020010
[drm] Raw DCB entry 6: 0000000e 00000000
Comment 2 Ben Skeggs 2009-03-26 19:06:30 EDT
What do you see from running "plymouth-set-default-plugin" ?
Comment 3 Niels Haase 2009-03-27 00:40:18 EDT
"plymouth-set-default-plugin" shows "solar"
Comment 4 Niels Haase 2009-03-27 01:02:19 EDT
I saw an ohter problem in relation to the plymouth-plugin. It seams that I got dependency problems.

Packages skipped because of dependency problems:
    plymouth-libs-0.7.0-0.2009.03.09.1.fc11.x86_64 from rawhide
    plymouth-plugin-label-0.7.0-0.2009.03.09.1.fc11.x86_64 from rawhide
    plymouth-plugin-solar-0.7.0-0.2009.03.09.1.fc11.x86_64 from rawhide

Current Versions are:
plymouth-scripts-0.7.0-0.2009.03.09.1.fc11.x86_64
plymouth-plugin-solar-0.6.0-2.fc11.x86_64
plymouth-plugin-label-0.6.0-2.fc11.x86_64
plymouth-gdm-hooks-0.7.0-0.2009.03.09.1.fc11.x86_64
plymouth-0.7.0-0.2009.03.09.1.fc11.x86_64
plymouth-system-plugin-0.7.0-0.2009.03.09.1.fc11.x86_64
plymouth-libs-0.6.0-2.fc11.x86_64
plymouth-utils-0.7.0-0.2009.03.09.1.fc11.x86_64
plymouth-system-plugin-0.6.0-2.fc11.x86_64

please see the attached logfile "plymouth_dep_prob" of yum trying (with --skip-broken) to resolving the dependencies.
Comment 5 Niels Haase 2009-03-27 01:03:47 EDT
Created attachment 336949 [details]
dependency problem with plymouth
Comment 6 Adam Williamson 2009-03-27 17:29:29 EDT
for a quick check could you boot with the live CD and see if it works there?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Niels Haase 2009-03-28 08:03:28 EDT
(In reply to comment #6)
> for a quick check could you boot with the live CD and see if it works there?
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers  

boot from live CD with nouveau.modeset=1 works!. Correct resolution and graphical boot progress screen is shown.
Comment 8 Niels Haase 2009-03-28 08:50:08 EDT
(In reply to comment #4)
> I saw an ohter problem in relation to the plymouth-plugin. It seams that I got
> dependency problems.
> 
> Packages skipped because of dependency problems:
>     plymouth-libs-0.7.0-0.2009.03.09.1.fc11.x86_64 from rawhide
>     plymouth-plugin-label-0.7.0-0.2009.03.09.1.fc11.x86_64 from rawhide
>     plymouth-plugin-solar-0.7.0-0.2009.03.09.1.fc11.x86_64 from rawhide
> 
> Current Versions are:
> plymouth-scripts-0.7.0-0.2009.03.09.1.fc11.x86_64
> plymouth-plugin-solar-0.6.0-2.fc11.x86_64
> plymouth-plugin-label-0.6.0-2.fc11.x86_64
> plymouth-gdm-hooks-0.7.0-0.2009.03.09.1.fc11.x86_64
> plymouth-0.7.0-0.2009.03.09.1.fc11.x86_64
> plymouth-system-plugin-0.7.0-0.2009.03.09.1.fc11.x86_64
> plymouth-libs-0.6.0-2.fc11.x86_64
> plymouth-utils-0.7.0-0.2009.03.09.1.fc11.x86_64
> plymouth-system-plugin-0.6.0-2.fc11.x86_64
> 
> please see the attached logfile "plymouth_dep_prob" of yum trying (with
> --skip-broken) to resolving the dependencies.  

The dependencies problem is solved (remove all plymouth packages and install it again). But still no graphical boot screen. But there is another message who not appear in the dmesg logfile. I need many reboots to get the hole message:

(it shows it after the "Unknown boot option `nouveau.modeset=1': ignoring" message)

/bin/plymouthd: symbol lookup error: /bin/plymouthd: undefined symbol: ply_window_add_escape_handler
could not read byte from child: Success

after that the resolution changed and it displays:

[drm:nv50_display_command] *ERROR* timeout: 0x610300 = 0x80010081

and continue the boot process in the native resolution without any graphical boot screen to gdm.
Comment 9 Adam Williamson 2009-03-30 15:42:58 EDT
I suspect this is an idiosyncracy of your particular Rawhide install. It's certainly not a bug in nouveau, since it works on the live CD, so I'm going to close it. You could report a bug against plymouth, but I rather suspect it's not a general bug, just something odd that's happened to your particular install, so that may not be worthwhile.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Niels Haase 2009-04-01 18:19:33 EDT
Just for information. Adams is right. After an upgrade to beta the graphical boot screen works not! Thanks for your time and help!

Note You need to log in before you can comment on or make changes to this bug.