Bug 492480 - V4L-DVB module issue - NTSC tuning doesn't stay tuned.
V4L-DVB module issue - NTSC tuning doesn't stay tuned.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Mauro Carvalho Chehab
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 18:04 EDT by Rusty Scott
Modified: 2013-07-04 18:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 15:05:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of dmesg after enabling debug messages (37.25 KB, text/plain)
2009-03-30 15:16 EDT, Rusty Scott
no flags Details

  None (edit)
Description Rusty Scott 2009-03-26 18:04:51 EDT
Description of problem:
Under kernel 2.6.27.19-170.2.35.fc10.i686 using the V4L driver and a pcHDTV HD5500 tuner card, the V4L tuner doesn't stay tuned to the selected channel.  Verified using tvtime and mythtv.  Tested against a 2.6.27.11-generic kernel under different distro and problem doesn't exist there.  The problem occurs only through the V4Lx interface and not the DVB interface.

Version-Release number of selected component (if applicable):
kernel 2.6.27.19-170.2.35.fc10.i686

How reproducible:
I was helping another person who had this issue and I duplicated it on an independent setup.  I was also able to verify that problem doesn't exist in similar kernel versions of other distros.

Steps to Reproduce:
1. Using a pcHDTV HD5500 tv card (I assume the problem would happen in similar cards) with the cx88* modules loaded.
2. Start tvtime and tune to a known station.
3. begin audio capture using
> arecord -D hw:1,0 -r 48000 -c 2 -f S16_LE | aplay -
3. Video will appear briefly (.5-2 sec) and then disappear.
4. Captured audio will also disappear as if tuner channel has been changed to nonexistent channel.
  
Actual results:
Video and audio appear briefly on channel change to a known channel and then disappear.

Expected results:
Video and audio from tuned station remains on screen until channel is changed or application shuts down.

Additional info:
Have tried using both tvtime and mythtv.  TVtime is the simplest interface to use of the two, so all steps reported using tvtime.  I have also tested this on another distro's kernel 2.6.27.11-generic and the problem doesn't exist there which is why this is posted as fedora specific.
Comment 1 Mauro Carvalho Chehab 2009-03-28 05:58:23 EDT
Could you please load the modules with debug options enabled? You'll need to create a file at /etc/modprobe.d/v4l, and add those inside:

options tuner debug=1
options cx8800 video_debug=1

You can retrieve the logs by running the command:
   dmesg

I need the output of the dmesg command after the station to disappear.
Comment 2 Rusty Scott 2009-03-30 15:16:13 EDT
Created attachment 337238 [details]
Output of dmesg after enabling debug messages

Attached is the output of the dmesg command after enabling the debug options specified above and rebooting to get a "fresh" load of all modules.  You will notice there are several frequency changes.  TVTime started on CH13 but I didn't get the "flash" of tuned picture, I then tuned down to CH12 (no signal here) and CH11 (which also didn't show the flash).  I then returned to CH13 (through Ch12) which gave me the brief show of signal and then disappeared.  I halted TVtime and ran:

> dmesg > debug_log
Comment 3 Mauro Carvalho Chehab 2009-03-30 18:12:55 EDT
This doesn't seem to be kernel-related. Your board has a simple LG TDVS-H06xF tuner. The tuner commands are arriving at the tuner code.

So, I suspect that your trouble may be caused by one of those troubles:

1) Sometimes signal detection is not working (it depends on your tuner/board combination). Try to disable signal detection on tvtime;

2) The sensibility of PCI TV boards is much worse than a TV set. So, you'll need a strong signal for it to work, especially if you're using antenna. In this case, you'll need a better antenna (or better positioning it);

3) If you're using a different frequency table, the quality of the signal could be bad. Try to change the frequency table to properly reflect the frequency of your channels. If you are using Cable TV, you'll need to use the proper Cable TV table (there are two different ones for NTSC).

4) tvtime has a scan mode  (tvtime-scanner). This only works if signal detection is ok. You may use it instead of a fixed Cable TV table. Depending on your Cable TV, this is required.

So, please test the above and give us some feedback.
Comment 4 Rusty Scott 2009-03-31 15:54:11 EDT
This issue doesn't exhibit itself when running a different linux distro with the same kernel release on the identical hardware with identical input.  On that distro, tvtime will hold the channel and show video.  The issue was brought to my attention while I was helping someone in a different region, with different signal inputs, try to figure out why his card wouldn't show V4Lx video.  I duplicated his setup under Fedora 10 and experienced the same problem.  I do not have the problem under other distros with the same kernel version.  The problem also shows under mythtv.

I am trying to build the driver modules using code directly from linuxtv.org but am still having some build issues. I have experienced problems building the drivers directly from linuxtv.org under Fedora in the past because Fedora will often release portions of the next kernel revision under the current kernel revision.  I will keep trying to build and test the linuxtv drivers, but because the same kernel version works on other distros, I am sure this is a Fedora specific issue.

Specifically regarding #4) above: tvtime's scanner/signal detection is fast enough that it detects the brief duration of signal present to put the station into the active station list. I don't see this as being a signal quality/detection issue. Also Re: #3) I am using the us-bcast table for grabbing OTA stations. And I know the signal is strong enough because I can tune them using the same system with a different distro.
Comment 5 Rusty Scott 2009-04-08 15:05:35 EDT
On further investigation, this turned out to be a configuration problem in setting up MythTV.  MythTV was keeping the DVB interface open on the card causing the V4L interface to not work correctly. The MythBackend process would continue to run an keep the problem evident while testing with TVTime.  When tested on fresh installs of Fedora prior to MythTV being installed the problem does not exist.  Sorry for any inconvenience.

Note You need to log in before you can comment on or make changes to this bug.