Bug 492481 - channel.software.clone method creates custom channel, NOT cloned channel
channel.software.clone method creates custom channel, NOT cloned channel
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
520
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
Sayli Karmarkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 18:09 EDT by Stanislav Polasek
Modified: 2015-03-22 21:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 04:47:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
simple script to test the problem (459 bytes, application/octet-stream)
2009-03-26 18:09 EDT, Stanislav Polasek
no flags Details

  None (edit)
Description Stanislav Polasek 2009-03-26 18:09:30 EDT
Created attachment 336919 [details]
simple script to test the problem

Description of problem:
Python channel.software.clone method creates standard custom channel, not cloned channel.

Version-Release number of selected component (if applicable):
5.2

How reproducible:
Allways

Steps to Reproduce:
1. use script to create cloned channel
2. check web ui: Channels->Manage Software Channels->click on channel name
3. "Details" tab does not list the "Cloned From:" property
4. "Errata" tab does not list the "Clone" option

Actual results:
Standard custom channel

Expected results:
Cloned channel

Additional info:
Attached the simple script to test
Comment 1 Stanislav Polasek 2009-03-27 02:53:38 EDT
I can confirm the same problem even using perl script, so it's not limited to python:

#!/usr/bin/perl -w
use strict;
use Frontier::Client;

my $HOST = 'localhost';
my $user = 'username';
my $pass = 'password';

my $client = new Frontier::Client(url => "http://$HOST/rpc/api");
my $session = $client->call('auth.login', $user, $pass);

my %newchannel = (
        name    => "testname",
        label   => "testlabel",
        summary => "testsummary"
);
my $cid = $client->call( "channel.software.clone", $session, "rhel-i386-as-4", \%newchannel, $client->boolean(0) );

$client->call('auth.logout', $session);
Comment 2 Stanislav Polasek 2009-03-27 02:55:29 EDT
Changed bug subject, it's not limited to python.
Comment 3 Stanislav Polasek 2009-03-31 04:47:08 EDT
I have found the cloning is actually being deprecated, so this is probably not a bug. Closing.

Note You need to log in before you can comment on or make changes to this bug.