Bug 492486 - wlan0 instantly diassociates [NEEDINFO]
wlan0 instantly diassociates
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
i686 Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-03-26 18:44 EDT by Paul M Baggenstoss
Modified: 2009-07-14 13:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-07-14 13:53:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dcbw: needinfo? (pbaggens)

Attachments (Terms of Use)

  None (edit)
Description Paul M Baggenstoss 2009-03-26 18:44:58 EDT
I installed a Netgear WG511 (v1) pcia wlan card in a Thinkpad 570E running Fedora 9.  After adding firmware file to /lib/firmware directory, card comes up, connects to access point, lights blink and iwconfig looks right. But ifconfig shows no  ip address.

dmesg shows this line:

wlan0: disassociating by local choice (reason=3)

Here's my workaround:

Added these lines to startup script

/etc/init.d/NetworkManager  stop
/usr/sbin/wpa_supplicant  -B -Dprism54 -iwlan0 \
/sbin/dhclient wlan0

Then it works...

Version is:

Comment 1 Paul M Baggenstoss 2009-03-26 20:37:51 EDT
forgot to say : kernel is
Comment 2 Dan Williams 2009-03-27 15:38:56 EDT
Does the problem still happen if you use the 'wext' driver for wpa_supplicant instead of the prism54 driver?
Comment 3 Paul M Baggenstoss 2009-03-27 21:56:47 EDT
If you mean replacing -Dprism54 with -Dwext in the script above, I tried that and it was a disaster. wpa_supplicant first reported it was associated, then it reported that network was down. Furthermore, dhclient hangs.  This happened two times in two tries. When I put -Dprism54 back in, it worked again. Thanks.
Comment 4 Jessica Sterling 2009-03-31 09:32:35 EDT
This bug has been triaged.

Fedora Bugzappers volunteer triage team
Comment 5 Dan Williams 2009-04-08 21:39:51 EDT
Are you using the 'p54' driver for your card, or the prism54 driver?  If you blacklist 'prism54' in /etc/modprobe.conf, and find the right firmware here:


(put the files in /lib/firmware)

then restart, and use the -Dwext wpa_supplicant driver, does that help things?

The problem is that the 'prism54' wpa_supplicant driver is deprecated because it doesn't use the standard interfaces.  It is not enabled for F-10 and above.  If there are bugs with the 'wext' driver, we need to fix those instead so that you can use it.
Comment 6 Niels Haase 2009-04-28 17:26:27 EDT
Reporter, could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

Fedora Bugzappers volunteer triage team
Comment 7 Bug Zapper 2009-06-09 23:38:46 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 8 Bug Zapper 2009-07-14 13:53:39 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.