Bug 492490 - RFE: include contrib/ in %doc
RFE: include contrib/ in %doc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Todd Zullinger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 19:20 EDT by Chris Weyl
Modified: 2013-01-10 05:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-04 19:08:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Weyl 2009-03-26 19:20:15 EDT
The Git tarball has a rich contrib/ directory.  I see some of these are already included in various subpackage's %doc, but can we include all of it somewhere?  I can see it being useful to be able to do access these without having to go poking through the sources :-)
Comment 1 Todd Zullinger 2009-03-26 20:46:37 EDT
Sounds reasonable to me.  I know there have been things in contrib/ that I've had to grab here and there.  Just a few concerns I have off the top of my head...

We include contrib/hooks currently, which ends up at /usr/share/doc/git-*/hooks.  I wonder if anyone will get annoyed if we include contrib/, and then the hooks end up at /usr/share/doc/git-*/contrib/hooks?  The version changes frequently, so it seems reasonable to assume anyone using that has to do manual work anyway.  Besides, they should be using the hooks from /usr/share/git-core/templates/hooks/ instead.

If we don't go to some effort to exclude files that are included elsewhere, won't we run afoul of https://fedoraproject.org/wiki/Packaging:Guidelines#Duplicate_Files ?  We already do duplicate some %doc files, but I haven't had time to see about fixing that yet.

I'm guessing we'll also pick up some rpmlint complaints, some of which may be things we can ignore -- though it's nice to keep the the output to a minimum, so actual problems can be spotted.

And somewhere in the back of my mind, I think I recall reading that rpm picks up requires/provides even in %doc files?  If that's true, we'll have to watch that we don't pick up any spurious requires/provides.  (I'd be happy to be told I'm just delirious from lack of rum and that this isn't a problem. ;)
Comment 2 Todd Zullinger 2009-04-04 19:08:52 EDT
I just built git-1.6.2.2-1.fc11 for rawhide and it includes the contrib dir.  I stripped execute perms from any files that had them, to avoid a lot of rpmlint complaining and the possibility of picking up unintended requires/provides.  Yell if you notice any problems with this.

Note You need to log in before you can comment on or make changes to this bug.