Bug 492538 - Network Manager is dead but pid file exists
Network Manager is dead but pid file exists
Status: CLOSED DUPLICATE of bug 492246
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 06:44 EDT by markm
Modified: 2009-03-27 11:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-27 11:50:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash of NM (9.68 KB, text/plain)
2009-03-27 09:02 EDT, Dušan Hokův
no flags Details

  None (edit)
Description markm 2009-03-27 06:44:09 EDT
Description of problem:

I've started my laptop today and there was no network. Network Manager was started, but died:

[root@m4300 ~]# /etc/init.d/NetworkManager status
NetworkManager dead but pid file exists
[root@m4300 ~]# /etc/init.d/NetworkManager start
Setting network parameters...                              [  OK  ]
Starting NetworkManager daemon:                            [  OK  ]
[root@m4300 ~]# /etc/init.d/NetworkManager status
NetworkManager dead but pid file exists
[root@m4300 ~]#

I've restarted my laptop two times, no change.

Version-Release number of selected component (if applicable):

[root@m4300 ~]# rpm -qa | grep NetworkManager
NetworkManager-gnome-0.7.0.99-4.git20090324.fc10.i386
NetworkManager-glib-0.7.0.99-4.git20090324.fc10.i386
NetworkManager-0.7.0.99-4.git20090324.fc10.i386
[root@m4300 ~]# 

How reproducible:

always

Additional info:

I've managed to start wired connection via Network applet from System -> Administration, when I tried to start NM after that, my pidgin thought it got disconnected while I could still ping internet from command line.
Comment 1 markm 2009-03-27 07:34:40 EDT
downgrade to:

NetworkManager-glib-0.7.0-0.11.svn4229.fc10.i386
NetworkManager-gnome-0.7.0-0.11.svn4229.fc10.i386
NetworkManager-0.7.0-0.11.svn4229.fc10.i386

solved the problem
Comment 2 Dušan Hokův 2009-03-27 09:02:53 EDT
Created attachment 337005 [details]
crash of NM

NM crashed after successful connect to openvpn type vpn.
Comment 3 Dušan Hokův 2009-03-27 09:50:04 EDT
downgrade to:

NetworkManager-glib-0.7.0.99-3.fc10.i386
NetworkManager-0.7.0.99-3.fc10.i386
NetworkManager-vpnc-0.7.0.99-1.fc10.i386
NetworkManager-gnome-0.7.0.99-3.fc10.i386
NetworkManager-openvpn-0.7.0.99-1.fc10.i386
NetworkManager-pptp-0.7.0.99-1.fc10.i386

solve my problem
Comment 4 Dušan Hokův 2009-03-27 09:56:42 EDT
I downgraded only NM, NM-glib and NM-gnome and it works for me.
Comment 5 yunus 2009-03-27 11:50:02 EDT

*** This bug has been marked as a duplicate of bug 492246 ***

Note You need to log in before you can comment on or make changes to this bug.