Bug 492572 - Blurry image in gstreamer with nouveau "NV30 high quality adapter"
Blurry image in gstreamer with nouveau "NV30 high quality adapter"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 10:15 EDT by A.C.Heron
Modified: 2009-05-11 08:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 08:41:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A.C.Heron 2009-03-27 10:15:48 EDT
Description of problem: 
With nouveau driver on NV34 chip (GeForce FX 5500) gstreamer test gives blurry picture if  "NV30 high quality adapter" is selected. Other deices work fine.

Version-Release number of selected component (if applicable):
nouveau driver from livecd-fedora-testday-nouveau-20090325 CD.

How reproducible:
always.

Steps to Reproduce:
1. Boot from livecd-fedora-testday-nouveau-20090325
2. Run gstreamer-properties
3. In Video section set the Output Plugin to X Window System (X11/XShm/Xv)
4. Set Device to "NV30 high quality adapter"
5. Press the Test button. 
  
Actual results:
The test video will be blurry.

Expected results:
With other devices the test video is clear, colored bars do not overlap, every dot in the bottom-right corner is discernible.

Additional info:
tested on x86_64 architecture.
Comment 1 Ben Skeggs 2009-05-04 04:48:31 EDT
Can you test xorg-x11-drv-nouveau-0.0.12-33.20090501gitf69b34a.fc11, this should be fixed there.
Comment 2 A.C.Heron 2009-05-10 19:50:27 EDT
(In reply to comment #1)
> Can you test xorg-x11-drv-nouveau-0.0.12-33.20090501gitf69b34a.fc11, this
> should be fixed there.  

I sent you an e-mail, but got no answer. I'm asking here then. Is there a LiveCD or LiveUSB image with this version of the driver? If it doesn't exist, where can I get the packages to install this version on the system working off the 20090325 Testday LiveCD?
Comment 3 Ben Skeggs 2009-05-10 20:03:27 EDT
Sorry about that!  I don't believe that version made it to a new livecd, you can grab the latest build of xorg-x11-drv-nouveau from http://koji.fedoraproject.org/koji/buildinfo?buildID=101314 however.
Comment 4 A.C.Heron 2009-05-11 03:55:29 EDT
With the latest version X refuses to load. It gives the following error in Xorg.0.log:
(EE) EXA(0): driver's EXA version requirements (2.5) are incompatible with EXA version (2.4)

What other packages do I need to update?
Comment 5 Ben Skeggs 2009-05-11 05:04:28 EDT
Ouch, since you're using the livecd the earlier nouveau packages may work for you still, the build for -33 is http://koji.fedoraproject.org/koji/buildinfo?buildID=100747.

If you still see the ABI mismatch message, xorg-x11-server-Xorg and friends will need updating.

Thanks again!
Comment 6 A.C.Heron 2009-05-11 07:57:54 EDT
The old build works fine. Should I close the bug?
Comment 7 Ben Skeggs 2009-05-11 08:41:20 EDT
Thanks for that :)  Will close it with this comment!

Note You need to log in before you can comment on or make changes to this bug.