Bug 492576 - Battery not recognized after suspend/resume HP Pavilion dv7 laptop
Battery not recognized after suspend/resume HP Pavilion dv7 laptop
Status: CLOSED DUPLICATE of bug 490684
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 10:36 EDT by Don Harden
Modified: 2015-03-04 20:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 08:43:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Harden 2009-03-27 10:36:02 EDT
I have the following:
 HP Pavilion dv7 laptop with an Intel Core2 Duo T9400 and 4 GB of RAM
  Fedora 10  2.6.27.15-170.2.24.fc10.x86_64
  pm-utils-1.2.2.1-2.fc10
  hal-0.5.12-14.20081027git.fc10

Everything runs great including suspending, hibernating and resuming except that when the laptop resumes from a suspend or hibernation there is no battery info:   
> cat /proc/acpi/battery/BAT0/*
present:                 no
present:                 no
present:                 no


Before a suspend or hibernation and resume the battery info is as expected:  
> cat /proc/acpi/batter/BAT0/*                                                  
alarm:                   unsupported
present:                 yes
design capacity:         5100 mAh                                         
last full capacity:      4800 mAh                                   
battery technology:      rechargeable                                         
design voltage:          14400 mV                                
design capacity warning: 240 mAh                                      
design capacity low:     144 mAh      
capacity granularity 1:  264 mAh             
capacity granularity 2:  3780 mAh                                      
model number:            Primary                          
serial number:                    
battery type:            Lion
OEM info:                Hewlett-Packard
present:                 yes
capacity state:          ok
charging state:          charging
present rate:            0 mA
remaining capacity:      3679 mAh
present voltage:         16768 mV


Version-Release number of selected component (if applicable):
  pm-utils-1.2.2.1-2.fc10
  hal-0.5.12-14.20081027git.fc10


How reproducible:
Everytime the laptop goes through a suspend/resume cycle

Steps to Reproduce:
1. Boot the laptop
2. suspend
3. resume
  
Actual results:
No battery detected

Expected results:
Accurate report of battery state

Additional info:
It does not matter if the laptop is running on AC power or the battery

Booting with every combination of turning acpid on or off and turning the pci=noapci  kernel flag on or off  has no effect.

I spent a good deal of time Googling and searching the pm-utils archives but found no solution.

I've also tried the suggestions on the HAL Quirk site, http://people.freedesktop.org/~hughsient/quirk/index.html  but still no joy.
Comment 1 Gustavo Maciel Dias Vieira 2009-04-12 21:45:38 EDT
Same problem on an HP Pavilion dv4-1125br.
Comment 2 Jarod Wilson 2009-04-13 08:43:37 EDT

*** This bug has been marked as a duplicate of bug 490684 ***

Note You need to log in before you can comment on or make changes to this bug.