Bug 492577 - Fedora 10 DVD installation corrupted my partitions
Fedora 10 DVD installation corrupted my partitions
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 10:37 EDT by MirceaKitsune
Modified: 2009-03-30 11:15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-30 11:15:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description MirceaKitsune 2009-03-27 10:37:45 EDT
Yesterday I tried installing Fedora 10 DVD 64bit to dual-boot with Windows and it broke almost all my partitions although I had chosen partitioning correctly in the installer. This is my configuration and the steps I followed in detail:

My partition and HDD configuration is two hard disks partitioned like this: HDD1 (main hard disk): 1st partition - NTFS with Windows XP installed (C:). 2nd partition - Linux ext3 on which I had Linux Opensuse 11 installed - 3rd partition: Linux swap. 4th partition - Another NTFS partition on which I store files (No OS installed, extended). HDD2 (secondary hard disk): A single NTFS partition on which I store files again, this HDD should not be touched by the installer in any way except mounting.

So before the install I had Windows XP and OpenSuse 11 dual-boot installed over the configuration above and working correctly. As written above, both Windows and Linux are installed on the same main HDD but in different partitions.

Yesterday I tried replacing Opensuse with Fedora 10 which I want to use now, and tried installing it by formatting the partitions Opensuse was on and putting Fedora 10 there instead, of course without touching any NTFS partition and being able to still dual-boot Windows XP and Fedora.

When the Fedora 10 setup reached the partitioning part, I chosen the option "Use only Linux partitions" (or something like that) from the drop-down menu, then checked the checkbox "review my partition setup". When I clicked Next I entered the list showing me the partitions that would be used. They were exactly as I wanted them to so I clicked Next and started installing.

A note to add here: By default the setup wanted to install the bootloader on HDD2, my alternative HDD which I use for storing files that should not be touched by the installer in any way. However from the drop-down list showing both of my hard disks I selected the correct one manually (HDD1 where Linux and Windows were).

After Fedora finished installing all packets and asked me to restart, when my computer attempted to boot from my hard disk again it said "Grub loading..." like its normal but then "Error: 7" and stopped there, which means the bootloader did not install correctly (I got no error messages during the Fedora install btw). When I got to see my partitions with the Windows XP install disk, this is how my partitioning changed after Fedora attempted to be installed:

HDD1: C: on which I previously had Windows had become D:, and D: became E:. As for the Linux partitions which had to be (re)used, the little one which I think should have been swap was ext3 instead, while the larger one which Linux should have been on had some sort of format called "Windows recovery partition" or something like that (I think a corrupted partition format). There was also some "unknown disk" in the partitions list there...

HDD2: Although the NTFS partition I had there was still readable from windows which helped me save my data, the partition table of that hard disk was corrupted which could be seen with partition management software. I had to transfer my data, reformat and repartition the entire HDD and put it back in order to fix it.

Sadly the only steps to reproduce is trying to install with the same configuration on a partition and HDD layout similar to mine. This is all detail I remember but if Fedora 10 can do that to the partitions while its setup is set so everything goes correctly it might be a very major issue.
Comment 1 Tristan Santore 2009-03-27 11:28:46 EDT
This report was discussed in #fedora, and found to be a user problem.
Comment 2 MirceaKitsune 2009-03-27 14:37:29 EDT
I still don't believe it was a user problem personally. As I said the installer told me a certain partition setup would be used but then the partitions got -corrupted-, which means something went wrong that I didn't know of.

Anyway I managed to install it by choosing "manual partition layout" rather then the default "delete all linux partitions and create a new default layout". The problem which I 95% believe caused my HDDs to get corrupted was LVM. I'm not familiar with it but LVM seems to create some partition tables that might corrupt Windows installs and NTFS partitions in some cases.
Comment 3 Joel Andres Granados 2009-03-30 05:18:54 EDT
This is not a parted issue, its an anaconda issue.
moreover, the anaconda team has been working hard to address installation issues related to storage.  We encourage you to retest using F11 beta or anaconda git head.
Comment 4 Chris Lumens 2009-03-30 10:36:04 EDT
This is going to be extremely difficult to track down, unfortunately.  Do you have any information saved from the installation, such as the /var/log/anaconda.log and /var/log/anaconda.syslog?  Additionally, retesting with F11 beta is probably the best thing to due given the massive changes Joel referred to, though I understand how you might be rather nervous to attempt that.
Comment 5 MirceaKitsune 2009-03-30 11:11:38 EDT
For the moment I switched back to another Linux distro (I still like Fedora a lot, it's a very good distro but probably didn't suit me as well) so sadly I can't provide any new info or test more. Probably it's fixed in version 11 though.
Comment 6 Chris Lumens 2009-03-30 11:15:56 EDT
Closing on the basis of comment #5 for now.  Please feel free to reopen this bug if you are able to reproduce at a later date and gather some more information.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.