Bug 492584 - Anaconda only displays the second Intel RAID set on a two RAID set configuration
Anaconda only displays the second Intel RAID set on a two RAID set configuration
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 11:08 EDT by Alexandru Constantin Minoiu
Modified: 2009-06-25 13:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 13:39:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of dmraid -ay -vvv -ddd (4.47 KB, text/plain)
2009-03-27 11:11 EDT, Alexandru Constantin Minoiu
no flags Details
Output of ls -l /dev/mapper after the dmraid command (333 bytes, text/plain)
2009-03-27 11:13 EDT, Alexandru Constantin Minoiu
no flags Details
anaconda file from 30-03-2009-1024-x86_64.img (12.00 KB, application/octet-stream)
2009-03-30 19:56 EDT, Alexandru Constantin Minoiu
no flags Details
Anaconda logs for the "path" issue with or without the "updates" option (70.59 KB, application/x-zip-compressed)
2009-03-31 10:20 EDT, Alexandru Constantin Minoiu
no flags Details
Screenshot of error with 01-04-2009-1028-x86_64.img (10.37 KB, image/png)
2009-04-01 10:01 EDT, Alexandru Constantin Minoiu
no flags Details

  None (edit)
Description Alexandru Constantin Minoiu 2009-03-27 11:08:30 EDT
Description of problem:
I have the following Intel RAID configuration ( ICH9R) :

RAID Volumes :
ID	Name	Level	Strip	Size		Status	Bootable
0	VolOS	RAID0	32KB	192.0GB		Normal	Yes
1	VolData	RAID0	128KB	1000.3GB	Notmal	Yes

Physical Disks:
Port	Drive Model		Serial #	Size	Type/Status(Vol ID)
2		WDC6400AAKS-2	...			596.2GB	Normal Disk(0,1)
3		WDC6400AAKS-2	...			596.2GB	Normal Disk(0,1)

The problem is that Anaconda only displays the second RAID set : VolData.
I shall attach the output of dmraid -ay -vvv -ddd and the resulting /dev/mapper listing.
Comment 1 Alexandru Constantin Minoiu 2009-03-27 11:11:56 EDT
Created attachment 337021 [details]
Output of dmraid -ay -vvv -ddd
Comment 2 Alexandru Constantin Minoiu 2009-03-27 11:13:32 EDT
Created attachment 337022 [details]
Output of ls -l /dev/mapper after the dmraid command
Comment 3 Alexandru Constantin Minoiu 2009-03-27 11:28:13 EDT
I forgot to mention the version of Anaconda : 11.5.0.38
The boot.iso was downloaded from:
http://download.fedora.redhat.com/pub/fedora/linux/development/x86_64/os/images/
Comment 4 Joel Andres Granados 2009-03-30 04:32:23 EDT
I have patched this issue for anaconda git from Friday 27th.  On my tests it pretty much works.  Would really appreciated if you can test with one of these updates images.  You can find documentation on using updates in http://fedoraproject.org/wiki/Anaconda/Updates.  The images are arch dependent, so use the correct one for your arch, or else it wont work.

x86_64: http://jgranado.fedorapeople.org/storage/testing/30-03-2009-1024-x86_64.img
i586: http://jgranado.fedorapeople.org/storage/testing/30-03-2009-1024-i586.img
Comment 5 Alexandru Constantin Minoiu 2009-03-30 19:54:21 EDT
Hi,
I have downloaded both images. First of all it's strange that the i586 one is 6MB
and the x86_64 one is only 1.6 MB . I have written the x86_64 image to
a flash drive with dd . I have booted the boot.iso image from 
http://download.fedora.redhat.com/pub/fedora/linux/development/x86_64/os/images/
(dated 30th March) . 
When I gave the updates parameter the installer asked me to specify the device
where the updates reside and I gave the correct answer ( I verified this by 
first mounting the device in the tty2 console and then unmounting it).
It found the files but gave me the error : "Exec of anaconda failed: Exec format
error", "Installed exited abnormally [1/1]" ... "You may safely reboot your
system". I have looked at the anaconda file after mounting the update and it's not
 a valid Python script , it does not begin with "#!/usr/bin/python" ,
I shall attach the anaconda file.

For the x86 case it did see all the RAID sets after I set the updates parameter.
But after I choose "Create custom layout" and click "Next" it throws an exception
in the python code. I complains about the line 931 in partition_gui.py :
devname = "%s" % device.path . The error is "AttributeError: "NoneType" object has
no attribute "path"" . This seems to indicate that "device" is not properly 
initialized. I have to say that this error is the same even if I don't use the
"updates" parameter in GRUB, so it's not the fault of the i586 img file.
Also the same error appears using the x86_64 boot.iso  .

I hope I can help in testing this further if you could give me a proper x86_64 img
file so that anaconda sees all the RAID sets.

Thank you very muth for your patience!

P.S. :
The sha1 checksums for the boot.iso files (dated 30th march) downloaded from
http://download.fedora.redhat.com/pub/fedora/linux/development/ are:
9a5f33b9287f8be9b6da52f3579eeec43e83effd  boot30x64.iso
4ba5d1808a231f73dab6f73aaf258ea848bdac20  boot30x86.iso

The checksums for the update images are:
13aa6f832d631dfa4bb245ab23e05b6cb5d60415  30-03-2009-1024-x86_64.img
01c9599067a61e9ac76b83a36a9381bc274bb634  30-03-2009-1024-i586.img
Comment 6 Alexandru Constantin Minoiu 2009-03-30 19:56:10 EDT
Created attachment 337261 [details]
anaconda file from 30-03-2009-1024-x86_64.img
Comment 7 Joel Andres Granados 2009-03-31 06:11:07 EDT
(In reply to comment #5)
> Hi,
> I have downloaded both images. First of all it's strange that the i586 one is
> 6MB
> and the x86_64 one is only 1.6 MB . 

That is strange, have to look at that.

I have written the x86_64 image to

> It found the files but gave me the error : "Exec of anaconda failed: Exec
> format

This is what happens if you use an x86_64 image on an i586 system.

> 
> For the x86 case it did see all the RAID sets after I set the updates
> parameter.
> But after I choose "Create custom layout" and click "Next" it throws an
> exception
> in the python code. I complains about the line 931 in partition_gui.py :
> devname = "%s" % device.path . The error is "AttributeError: "NoneType" object
> has
> no attribute "path"" . 

hrm I've seen this before, but not at this part of the code.  Can you provide the traceback and logs. (they are at /tmp/* at installation time)

FWIW, this "path" issue might already be resolved.  I have not hit it in my tests.  I'll keep testing your issue and provide a new updates image at the end of the my day.
Comment 8 Alexandru Constantin Minoiu 2009-03-31 10:17:22 EDT
Hi,
I have a Q6600 processor, 4GB RAM and Vista x64 so it's not an i586 system.

Regarding the "path" issue I think I have found in what conditions it
can be reproduced. First of all , it does not matter if you use the "updates"
parameter in GRUB. The error is apparent only if you have a flash drive
connected to the computer with an INVALID partition table, like the one
in 30-03-2009-1024-i586.img (which is an image of a partition but it does not have an MBR). So if you happen to have the flash drive connected and you hit
"Next" after choosing "Create custom layout" an exception is thrown .
I have written an empty partition table to the flash drive with fdisk. After
reboot, I went through the same steps in the installer and this time there
was no problem, the exception did not happen. Of course there is no problem
if the flash drive is not connected at all.
So what do you do if you want to use an "updates" image on a flash drive
and you don't want to have this error ? You can unplug the flash drive after
anaconda enters graphical mode (at the first installation screen). I have
verified this and indeed I was able to see all RAID sets and not have an error
after I choose "Create custom layout" and hit "Next".

Since I have 4GB RAM and and x64 processor I would like to test F11 Beta x64.
I hope the image that you'll provide me will work so that I can begin
the installation. 
I'll attach the logs for the x64 and x86 versions with the "path" issue.

Thanks.
Comment 9 Alexandru Constantin Minoiu 2009-03-31 10:20:43 EDT
Created attachment 337312 [details]
Anaconda logs for the "path" issue with or without the "updates" option
Comment 10 Joel Andres Granados 2009-03-31 12:59:47 EDT
(In reply to comment #8)
> Hi,
> I have a Q6600 processor, 4GB RAM and Vista x64 so it's not an i586 system.
thiis is all good, but if you are installing from a i586 tree, then your installation will be i586 and the x86_64 image will not work.  no matter what your computer has.

> So what do you do if you want to use an "updates" image on a flash drive
> and you don't want to have this error ? You can unplug the flash drive after
> anaconda enters graphical mode (at the first installation screen). I have
> verified this and indeed I was able to see all RAID sets and not have an error
> after I choose "Create custom layout" and hit "Next".
This is great!  can you pls open another bugzilla for this issue.  furthermore, given that you are not seeing this bug anymore and your installation was successful I'll go ahead and close this issue.
> 
> Since I have 4GB RAM and and x64 processor I would like to test F11 Beta x64.
> I hope the image that you'll provide me will work so that I can begin
> the installation. 
If you see any dmraid bugs in these tests feel free to reopen this bug.

> I'll attach the logs for the x64 and x86 versions with the "path" issue.

Use another bug for this.
> 
> Thanks.
Comment 11 Alexandru Constantin Minoiu 2009-03-31 15:06:34 EDT
Hi,
Of course I used the x86_64 boot.iso :
http://download.fedora.redhat.com/pub/fedora/linux/development/x86_64/os/images/
I was dated 30th March 2009 nd the sha1 sum was:
9a5f33b9287f8be9b6da52f3579eeec43e83effd
I retested and indeed I was using the correct arch. I did an uname -a in tty2
and among other thins it said "2.6.29-16.fc11.x86_64" . I hope this clears up
any misunderstanding.
I am reopening this bug as I've tested again with the image you provided
(30-03-2009-1024-x86_64.img) and it gave me the same error.

Thank you.
Comment 12 Joel Andres Granados 2009-04-01 05:13:10 EDT
I see whats going on.  This is totally my fault :), The script that was creating the images used x86_64 binaries in the i586 image, so you get those messages.  pls try these:

http://jgranado.fedorapeople.org/storage/testing/01-04-2009-1028-x86_64.img
http://jgranado.fedorapeople.org/storage/testing/01-04-2009-1028-i586.img
Comment 13 Alexandru Constantin Minoiu 2009-04-01 09:58:14 EDT
Hi,
The problem was with the x86_64 image, the i586 image worked fine (with the x86 
boot.iso of course). I age tested the new images that you kindly provided and 
it  seems that both are for the x86 arch. In fact after extracting the contents
of both images I've have run a program that checksums all files in the resulting
folders and the contents are exactly the same!
I'm attaching a screenshot which I took in vmware so that you can see the error about ELF32, when using the x86_64 image.


Thanks.
Comment 14 Alexandru Constantin Minoiu 2009-04-01 10:01:49 EDT
Created attachment 337534 [details]
Screenshot of error with 01-04-2009-1028-x86_64.img

I;ve used an x86_64 boot.iso. The reason I used vmware here is to be able
to take a screenshot. The same error appears when I boot the iso on the
host system.
Comment 15 Joel Andres Granados 2009-04-16 07:55:25 EDT
yes, this is totally expected, the x86_64 image contains files that are i586 specific.  The fact that your tests succeeded with the i586 images assures me that this issue is fixed.  I'm providing the x86_64 image (without so files!!!!) so you can be reassured of the result:

http://jgranado.fedorapeople.org/storage/testing/2009-04-16-1351-x86_64.img
Comment 16 Alexandru Constantin Minoiu 2009-04-16 15:08:54 EDT
Hi,
I have tested the latest boot.iso images for both x86_64 and x86 and they work!
The anaconda version is 11.5.0.44 . I think this bug report can be closed unless
there is someone else having these problems.

Thank you very much for your work!
Comment 17 Bug Zapper 2009-06-09 08:44:27 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.