Bug 492586 - cmdline mode prompts during loader for NIC selection
cmdline mode prompts during loader for NIC selection
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-03-27 11:14 EDT by James Laska
Modified: 2013-09-02 02:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 17:28:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (168.27 KB, image/jpeg)
2009-03-27 11:14 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-03-27 11:14:24 EDT
Created attachment 337023 [details]
Screenshot

Description of problem:

Doing a cmdline mode kickstart install stops and prompts for the NIC to use in loader.


Version-Release number of selected component (if applicable):

anaconda-11.5.0.38


Steps to Reproduce:
1. Initiate cmdline mode kickstart install on a system with *multiple* NICs
  
Actual results:

Loader prompts for which NIC to use.

Expected results:

cmdline mode should never prompt, we should emit a failure message and the user must supply the require NIC information via cmdline or kickstart.

Additional info:

See screenshot
Comment 1 Chris Lumens 2009-03-27 13:19:16 EDT
David - it looks like all we really need here is something like:

if (FL_CMDLINE(flags)) {
    fprinft(stderr, "No way to determine which NIC to use, and cannot ask in cmdline mode.  Halting.");
    exit(1);
}

in net.c:chooseNetworkInterface, right before the startNewt().  Does that sound about right?
Comment 2 David Cantrell 2009-03-27 16:47:13 EDT
(In reply to comment #1)
> David - it looks like all we really need here is something like:
> 
> if (FL_CMDLINE(flags)) {
>     fprinft(stderr, "No way to determine which NIC to use, and cannot ask in
> cmdline mode.  Halting.");
>     exit(1);
> }
> 
> in net.c:chooseNetworkInterface, right before the startNewt().  Does that sound
> about right?  

Yeah, that's exactly what we need.  Will be in anaconda-11.5.0.39-1 and later.

Note You need to log in before you can comment on or make changes to this bug.