Bug 492597 - rhel 4 clients do not list out upgradable packages
rhel 4 clients do not list out upgradable packages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Solaris (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: John Matthews
wes hayutin
systems/details/packages/upgradeableL...
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-03-27 12:14 EDT by wes hayutin
Modified: 2009-09-10 16:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:34:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-03-27 12:14:30 EDT
Description of problem:

on 3/23 build

recreate:
1. register rhel 4 client
2. software packages, upgradable
lists no packages

will update bug more in a bit
Comment 1 John Matthews 2009-03-27 17:01:39 EDT
Not able to reproduce this with latest ISO.

Yet I confirmed this behavior was broken on grandprix earlier.


On grandprix's case package_arch_id data was null for all packages from a rhel 4.7 client.  That limited PackageManager.upgradable() to return 0 packages.

select count(*) from rhnServerPackage where server_id = 'XXXXXXX' and package_arch_id is not null;

this would return 0



when running this on a different install (still looking at the same rhel 47 client) I see package_arch_id data is available

select count(*) from rhnServerPackage where server_id = '1000010617' and package_arch_id is not null;
  COUNT(*)
----------
       359
Comment 2 Brandon Perkins 2009-03-31 12:12:39 EDT
Wes, are you able to reproduce this?
Comment 3 wes hayutin 2009-04-07 09:23:29 EDT
moving to on_qa to test for a reproducible scenario
Comment 4 wes hayutin 2009-04-09 12:32:14 EDT
tested 3 rhel4 clients 2 work 1 does not..
I'm guessing the one box is fubar'd 
I'll keep an eye out for this..

verified
Comment 5 John Sefler 2009-08-31 12:22:08 EDT
Verified on staged (Satellite-5.3.0-RHEL5-re20090724.0) with updates from Aug 20, 2009

system > Software > Packages > Upgrade is properly listing upgradable packages

moving to RELEASE_PENDING
Comment 6 Brandon Perkins 2009-09-10 16:34:53 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.