Bug 492598 - mountd: refused unmount request from for : illegal port message seen on servers
mountd: refused unmount request from for : illegal port message seen on servers
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-03-27 12:33 EDT by Orion Poplawski
Modified: 2009-05-09 00:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.1.5-5.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-09 00:24:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
data.pcap - insecure option (7.25 KB, application/octet-stream)
2009-04-17 15:33 EDT, Orion Poplawski
no flags Details
data.pcap - no insecure option (6.85 KB, application/octet-stream)
2009-04-17 15:34 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2009-03-27 12:33:18 EDT
Description of problem:

Unmount requests from F11 machines are generating the following messages on my EL5.2 and F-10 servers:

 Mar 27 04:34:31 earth mountd[4873]: refused unmount request from flaky.cora.nwra.comfor /export/local (/export/local): illegal port 59377


Version-Release number of selected component (if applicable):
nfs-utils-1.1.5-2.fc11.x86_64
kernel-2.6.29-0.258.2.3.rc8.git2.fc11.x86_64


How reproducible:
Every unmount request.
Comment 1 Jimmy Dorff 2009-04-06 16:51:33 EDT
I see the same issue:
nfs-utils-1.1.5-4.fc11.i586
kernel: 2.6.29.1-46.fc11.i686.PAE
Comment 2 Orion Poplawski 2009-04-17 10:17:24 EDT
This will be annoying if this goes out with F11 final.  At least should be a release note with how to deal with it.
Comment 3 Steve Dickson 2009-04-17 12:41:16 EDT
Is iptables enabled on the F11 client?
Comment 4 Orion Poplawski 2009-04-17 12:45:04 EDT
Well, they are enabled in chkconfig, but I haven't changed the config files nor created /etc/sysconfig/iptables.
Comment 5 Steve Dickson 2009-04-17 13:16:28 EDT
ok.. I'm not seeing this...

I'm using 

nfs-utils-1.1.5-4.fc11.x86_64
kernel-2.6.29.1-70.fc11.x86_64

Is autofs in the picture?
Any non default mount options? (cat /proc/mounts | grep nfs)
What does the exports look like (cat /etc/exports)

anything you can think of that will help be reproduce this...
Comment 6 Orion Poplawski 2009-04-17 13:26:19 EDT
(In reply to comment #5)
> nfs-utils-1.1.5-4.fc11.x86_64
> kernel-2.6.29.1-70.fc11.x86_64

same

> Is autofs in the picture?

yes. These are all done via autofs.

> Any non default mount options? (cat /proc/mounts | grep nfs)

sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw,relatime 0 0
ldap://ldap.cora.nwra.com/ou=auto.nfs,dc=cora,dc=nwra,dc=com /nfs autofs rw,relatime,fd=23,pgrp=7888,timeout=300,minproto=5,maxproto=5,indirect 0 0
earth:/export/home/orion /home/orion nfs rw,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,hard,nointr,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.0.8,mountvers=3,mountproto=tcp,addr=192.168.0.8 0 0
alexandria:/export/cora /data/cora nfs rw,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,hard,nointr,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.0.13,mountvers=3,mountproto=tcp,addr=192.168.0.13 0 0
alexandria:/export/cora3 /data/cora3 nfs rw,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,hard,nointr,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.0.13,mountvers=3,mountproto=tcp,addr=192.168.0.13 0 0
alexandria:/export/cora2 /data/cora2 nfs rw,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,hard,nointr,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.0.13,mountvers=3,mountproto=tcp,addr=192.168.0.13 0 0
alexandria2:/export/cora4 /data/cora4 nfs rw,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,hard,nointr,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.0.16,mountvers=3,mountproto=tcp,addr=192.168.0.16 0 0
alexandria2:/export/cora5 /data/cora5 nfs rw,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,hard,nointr,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.0.16,mountvers=3,mountproto=tcp,addr=192.168.0.16 0 0
alexandria2:/export/cora6 /data/cora6 nfs rw,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,hard,nointr,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.0.16,mountvers=3,mountproto=tcp,addr=192.168.0.16 0 0

# mount | grep nfs
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
earth:/export/home/orion on /home/orion type nfs (rw,intr,rsize=32768,wsize=32768,sloppy,addr=192.168.0.8)
alexandria:/export/cora on /data/cora type nfs (rw,intr,rsize=32768,wsize=32768,sloppy,addr=192.168.0.13)
alexandria:/export/cora3 on /data/cora3 type nfs (rw,intr,rsize=32768,wsize=32768,sloppy,addr=192.168.0.13)
alexandria:/export/cora2 on /data/cora2 type nfs (rw,intr,rsize=32768,wsize=32768,sloppy,addr=192.168.0.13)
alexandria2:/export/cora4 on /data/cora4 type nfs (rw,intr,rsize=32768,wsize=32768,sloppy,addr=192.168.0.16)
alexandria2:/export/cora5 on /data/cora5 type nfs (rw,intr,rsize=32768,wsize=32768,sloppy,addr=192.168.0.16)
alexandria2:/export/cora6 on /data/cora6 type nfs (rw,intr,rsize=32768,wsize=32768,sloppy,addr=192.168.0.16)

not sure why sloppy appears here but not in /proc/mounts.

> What does the exports look like (cat /etc/exports)

earth:
/export/home    *.cora.nwra.com(rw,sync,no_subtree_check)
/export/local   *.cora.nwra.com(rw,sync,no_root_squash)

alexandria:
/export                 *.cora.nwra.com(rw,sync,fsid=0)
/export/cora            *.cora.nwra.com(rw,sync,nohide)
/export/cora2           *.cora.nwra.com(rw,sync,nohide)
/export/cora3           earth.cora.nwra.com(rw,sync,nohide,no_root_squash) *.cora.nwra.com(rw,sync,nohide)
Comment 7 Steve Dickson 2009-04-17 14:56:43 EDT
Question: if you set the 'insecure' export option on on of those
exports, does the problem go away??
Comment 8 Steve Dickson 2009-04-17 14:58:44 EDT
Also would it be possible to post a bzip2 binary tshark network trace?
something similar to:

tshark -w /tmp/data.pcap host <client> ; bzip2 /tmp/data.pcap
or
tshark -w /tmp/data.pcap host <server> ; bzip2 /tmp/data.pcap

either side would be good...

tia,
Comment 9 Orion Poplawski 2009-04-17 15:30:25 EDT
(In reply to comment #7)
> Question: if you set the 'insecure' export option on on of those
> exports, does the problem go away??  

Yes:

Apr 17 13:28:56 earth mountd[19327]: authenticated mount request from akialoa.cora.nwra.com:715 for /export/local (/export/local)
Apr 17 13:28:59 earth mountd[19327]: authenticated unmount request from akialoa.cora.nwra.com:40194 for /export/local (/export/local)
Comment 10 Orion Poplawski 2009-04-17 15:33:35 EDT
Created attachment 340074 [details]
data.pcap - insecure option

tshark dump.  no bzip2 since it's only 7422 bytes.
Comment 11 Orion Poplawski 2009-04-17 15:34:55 EDT
Created attachment 340076 [details]
data.pcap - no insecure option
Comment 12 Steve Dickson 2009-04-20 07:51:39 EDT
Fixed in nfs-utils-1.1.5-5.fc11
Comment 13 Fedora Update System 2009-04-21 11:34:40 EDT
nfs-utils-1.1.5-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/nfs-utils-1.1.5-5.fc11
Comment 14 Fedora Update System 2009-05-09 00:24:44 EDT
nfs-utils-1.1.5-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.