Bug 492615 - fails to save files over cifs
fails to save files over cifs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 14:17 EDT by Dimitri Papadopoulos
Modified: 2009-11-19 03:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-19 03:44:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of gedit error (27.51 KB, image/png)
2009-03-27 14:17 EDT, Dimitri Papadopoulos
no flags Details

  None (edit)
Description Dimitri Papadopoulos 2009-03-27 14:17:54 EDT
Created attachment 337049 [details]
screenshot of gedit error

Description of problem:
gedit fails to save files on CIFS shares
cat /nas/dimitri/foo.txt

Version-Release number of selected component (if applicable):
gedit-2.24.3-3.fc10.x86_64

How reproducible:
always

Steps to Reproduce:
1. Create a file on a CIFS share. For example:
$ cat >/nas/dimitri/foo.txt <<EOF
> 1234
> EOF
$ 
$ ls -l /nas/dimitri/foo.txt
-rwxrwxrwx 1 dimitri dimitri 5 Mar 27  2009 /nas/dimitri/foo.txt
$ 
$ mount | grep nas
//192.168.1.3/dimitri on /nas/dimitri type cifs (rw,mand,noexec,nosuid,nodev)
$ 
2. Edit that file.
3. Try to save.
  
Actual results:
Error messages pop up:
	Could not save the file ...
	Unexpected error: Invalid argument
The file is not saved.

Expected results:
The file is saved without questions.

Additional info:
I do understand this may be a cifs/smbfs limitation. However it is a real nuisance. I think it should be worked around if possible.
Comment 1 Dimitri Papadopoulos 2009-03-27 14:20:01 EDT
I have found the following bug report, but it's not the same error message so it's probably unrelated:
http://bugzilla.gnome.org/show_bug.cgi?id=336738
Comment 2 Dimitri Papadopoulos 2009-03-27 14:35:06 EDT
Additionally there's an error from the error popup. From stderr:

** (gedit:3737): WARNING **: Hit unhandled case 13 (Invalid argument) in parse_error.
Comment 3 Dimitri Papadopoulos 2009-03-27 14:42:45 EDT
Mmmh... Maybe it's related after all:
https://bugs.launchpad.net/ubuntu/+source/gedit/+bug/34813/comments/40
Comment 4 Dimitri Papadopoulos 2009-07-12 08:05:20 EDT
Still there in Fedora 11.
Comment 5 Bug Zapper 2009-11-18 06:37:15 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Dimitri Papadopoulos 2009-11-18 06:44:16 EST
Still there in Fedora 11 as I have already said.
Bumping 10 -> 11
Will test Fedora 12 soon.
Comment 7 Dimitri Papadopoulos 2009-11-19 03:44:27 EST
Seems to have been fixed in Fedora 12.
Unable to reproduce this gedit problem after upgrading.

Note You need to log in before you can comment on or make changes to this bug.