Bug 492620 - nm-applet/NetworkManager broken after latest yum update
nm-applet/NetworkManager broken after latest yum update
Status: CLOSED DUPLICATE of bug 492246
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 14:37 EDT by jedblack
Modified: 2009-03-27 15:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-27 15:30:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jedblack 2009-03-27 14:37:17 EDT
Description of problem:
I did a patch update via "yum update" and now the nm-applet is not displaying in the menu bar.

Here is a list of patches updated.
Mar 26 09:38:48 Updated: libselinux-2.0.78-1.fc10.i386
Mar 26 09:38:49 Updated: 1:NetworkManager-glib-0.7.0.99-4.git20090324.fc10.i386
Mar 26 09:38:50 Updated: 32:bind-libs-9.5.1-2.P2.fc10.i386
Mar 26 09:39:02 Updated: compiz-fusion-0.7.8-4.fc10.i386
Mar 26 09:39:07 Updated: 1:NetworkManager-0.7.0.99-4.git20090324.fc10.i386
Mar 26 09:39:08 Updated: httpd-tools-2.2.11-2.fc10.i386
Mar 26 09:39:08 Installed: apr-util-ldap-1.3.4-1.fc10.i386
Mar 26 09:39:10 Updated: mysql-libs-5.0.77-1.fc10.i386
Mar 26 09:39:13 Updated: libchewing-0.3.2-6.fc10.i386
Mar 26 09:39:32 Updated: nautilus-sendto-1.1.2-1.fc10.i386
Mar 26 09:39:36 Updated: libselinux-devel-2.0.78-1.fc10.i386
Mar 26 09:39:45 Updated: tzdata-2009d-1.fc10.noarch
Mar 26 09:39:46 Updated: libselinux-python-2.0.78-1.fc10.i386
Mar 26 09:39:57 Updated: compiz-fusion-gnome-0.7.8-4.fc10.i386
Mar 26 09:40:02 Updated: tzdata-java-2009d-1.fc10.noarch
Mar 26 09:40:07 Updated: gzip-1.3.12-8.fc10.i386
Mar 26 09:40:14 Updated: 1:NetworkManager-gnome-0.7.0.99-4.git20090324.fc10.i386
Mar 26 09:40:15 Updated: 32:bind-utils-9.5.1-2.P2.fc10.i386
Mar 26 09:40:19 Updated: httpd-2.2.11-2.fc10.i386
Mar 26 09:40:22 Updated: logwatch-7.3.6-35.fc10.noarch
Mar 26 09:40:23 Updated: libselinux-utils-2.0.78-1.fc10.i386
Mar 26 14:38:09 Updated: 1:java-1.6.0-openjdk-1.6.0.0-13.b14.fc10.i386
Mar 26 14:38:10 Updated: libmtp-0.3.7-1.fc10.i386
Mar 26 14:38:10 Updated: 1:java-1.6.0-openjdk-plugin-1.6.0.0-13.b14.fc10.i386


Version-Release number of selected component (if applicable):



How reproducible:
restart or logoff/login

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
[fseifts@fxslaptop ~]$ uname -a
Linux fxslaptop 2.6.27.19-170.2.35.fc10.i686.PAE #1 SMP Mon Feb 23 13:09:26 EST 2009 i686 i686 i386 GNU/Linux
[fseifts@fxslaptop ~]$ ps -ef |grep -i nm
root      2331     1  0 14:15 ?        00:00:00 /usr/sbin/nm-system-settings --config /etc/NetworkManager/nm-system-settings.conf
root      3164     1  0 14:16 ?        00:00:00 nmbd -D
fseifts   3732  3463  0 14:16 ?        00:00:00 nm-applet --sm-disable
fseifts   4296  3898  0 14:34 pts/0    00:00:00 grep -i nm

[fseifts@fxslaptop ~]$ su - root
Password: 
[root@fxslaptop ~]# service NetworkManager restart
Stopping NetworkManager daemon:                            [FAILED]
Setting network parameters...                              [  OK  ]
Starting NetworkManager daemon:                            [  OK  ]

[root@fxslaptop ~]# exit
logout

[fseifts@fxslaptop ~]$ nm-applet

** (nm-applet:4367): WARNING **: <WARN>  applet_dbus_manager_start_service(): Could not acquire the NetworkManagerUserSettings service as it is already taken.  Return: 3

[fseifts@fxslaptop ~]$ nm-applet --sm-disabled

** (nm-applet:4368): WARNING **: <WARN>  applet_dbus_manager_start_service(): Could not acquire the NetworkManagerUserSettings service as it is already taken.  Return: 3

[fseifts@fxslaptop ~]$ cat /etc/NetworkManager/nm-system-settings.conf
[main]
plugins=ifcfg-rh
[fseifts@fxslaptop ~]$
Comment 1 jedblack 2009-03-27 14:44:33 EDT
when I try to run NetworkManager in no daemon mode...

[root@fxslaptop NetworkManager]# NetworkManager --no-daemon
NetworkManager: <info>  starting...
-- Error received: File exists
-- Original message: type=0x14 length=56 flags=<REQUEST,ACK,ATOMIC> sequence-nr=1238179389 pid=4198860
NetworkManager: <WARN>  nm_generic_enable_loopback(): error -17 returned from rtnl_addr_add():
Sucess

NetworkManager: <info>  Found radio killswitch /org/freedesktop/Hal/devices/pci_8086_4229_rfkill_4965AGN_wlan
NetworkManager: <info>  Found radio killswitch /org/freedesktop/Hal/devices/dell_wlan_switch
NetworkManager: <WARN>  nm_signal_handler(): Caught signal 11.  Generating backtrace...
NetworkManager: ******************* START **********************************
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: [Thread debugging using libthread_db enabled]
NetworkManager: [New Thread 0xb7f63970 (LWP 4556)]
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: 0x00b90424 in __kernel_vsyscall ()
NetworkManager: #0  0x00b90424 in __kernel_vsyscall ()
NetworkManager: #1  0x0011e0b3 in __waitpid_nocancel () from /lib/libpthread.so.0
NetworkManager: #2  0x08075c73 in nm_logging_backtrace ()
NetworkManager: #3  0x08070395 in ?? ()
NetworkManager: #4  <signal handler called>
NetworkManager: #5  0x0806de9a in ?? ()
NetworkManager: #6  0x08077e98 in ?? ()
NetworkManager: #7  0x08086fd1 in _nm_marshal_VOID__STRING_STRING_POINTER_POINTER ()
NetworkManager: #8  0x006c11fb in g_closure_invoke () from /lib/libgobject-2.0.so.0
NetworkManager: #9  0x006d7655 in ?? () from /lib/libgobject-2.0.so.0
NetworkManager: #10 0x006d8d6c in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
NetworkManager: #11 0x006d91e6 in g_signal_emit () from /lib/libgobject-2.0.so.0
NetworkManager: #12 0x0806b917 in ?? ()
NetworkManager: #13 0x0806c21c in nm_hal_manager_query_devices ()
NetworkManager: #14 0x08076508 in ?? ()
NetworkManager: #15 0x0807849c in ?? ()
NetworkManager: #16 0x00608301 in ?? () from /lib/libglib-2.0.so.0
NetworkManager: #17 0x0060a238 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
NetworkManager: #18 0x0060d8e3 in ?? () from /lib/libglib-2.0.so.0
NetworkManager: #19 0x0060de02 in g_main_loop_run () from /lib/libglib-2.0.so.0
NetworkManager: #20 0x08070b94 in main ()
NetworkManager: 
NetworkManager: Thread 1 (Thread 0xb7f63970 (LWP 4556)):
NetworkManager: #0  0x00b90424 in __kernel_vsyscall ()
NetworkManager: No symbol table info available.
NetworkManager: #1  0x0011e0b3 in __waitpid_nocancel () from /lib/libpthread.so.0
NetworkManager: No symbol table info available.
NetworkManager: #2  0x08075c73 in nm_logging_backtrace ()
NetworkManager: No symbol table info available.
NetworkManager: #3  0x08070395 in ?? ()
NetworkManager: No symbol table info available.
NetworkManager: #4  <signal handler called>
NetworkManager: No symbol table info available.
NetworkManager: #5  0x0806de9a in ?? ()
NetworkManager: No symbol table info available.
NetworkManager: #6  0x08077e98 in ?? ()
NetworkManager: No symbol table info available.
NetworkManager: #7  0x08086fd1 in _nm_marshal_VOID__STRING_STRING_POINTER_POINTER ()
NetworkManager: No symbol table info available.
NetworkManager: #8  0x006c11fb in g_closure_invoke () from /lib/libgobject-2.0.so.0
NetworkManager: No symbol table info available.
NetworkManager: #9  0x006d7655 in ?? () from /lib/libgobject-2.0.so.0
NetworkManager: No symbol table info available.
NetworkManager: #10 0x006d8d6c in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
NetworkManager: No symbol table info available.
NetworkManager: #11 0x006d91e6 in g_signal_emit () from /lib/libgobject-2.0.so.0
NetworkManager: No symbol table info available.
NetworkManager: #12 0x0806b917 in ?? ()
NetworkManager: No symbol table info available.
NetworkManager: #13 0x0806c21c in nm_hal_manager_query_devices ()
NetworkManager: No symbol table info available.
NetworkManager: #14 0x08076508 in ?? ()
NetworkManager: No symbol table info available.
NetworkManager: #15 0x0807849c in ?? ()
NetworkManager: No symbol table info available.
NetworkManager: #16 0x00608301 in ?? () from /lib/libglib-2.0.so.0
NetworkManager: No symbol table info available.
NetworkManager: #17 0x0060a238 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
NetworkManager: No symbol table info available.
NetworkManager: #18 0x0060d8e3 in ?? () from /lib/libglib-2.0.so.0
NetworkManager: No symbol table info available.
NetworkManager: #19 0x0060de02 in g_main_loop_run () from /lib/libglib-2.0.so.0
NetworkManager: No symbol table info available.
NetworkManager: #20 0x08070b94 in main ()
NetworkManager: No symbol table info available.
NetworkManager: The program is running.  Quit anyway (and detach it)? (y or n) [answered Y; input not from terminal]
NetworkManager: ******************* END **********************************
[root@fxslaptop NetworkManager]#
Comment 2 Dan Williams 2009-03-27 15:30:06 EDT

*** This bug has been marked as a duplicate of bug 492246 ***

Note You need to log in before you can comment on or make changes to this bug.