Bug 492632 - file conflicts: file /usr/share/bookmarks/default-bookmarks.html conflicts between attempted installs of astronomy-bookmarks-1-4.fc11.noarch and fedora-bookmarks-10-2.noarch
file conflicts: file /usr/share/bookmarks/default-bookmarks.html conflicts be...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: astronomy-bookmarks (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Marek Mahut
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Preview
  Show dependency treegraph
 
Reported: 2009-03-27 15:07 EDT by James Laska
Modified: 2013-09-02 02:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 15:28:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2009-03-27 15:07:02 EDT
Description:
 * Manually installing all packages on F-11-Beta fails due to a dependency conflict

Steps to reproduce:
 * https://fedoraproject.org/w/index.php?title=QA/TestCases/PackageSetsEverything&action=edit&redlink=1 

Actual Results:

08:09:48 ERROR   : file conflicts: file /usr/share/bookmarks/default-bookmarks.html conflicts between attempted installs of astronomy-bookmarks-1-4.fc11.noarch and fedora-bookmarks-10-2.noarch
Comment 1 Tom "spot" Callaway 2009-04-15 15:25:51 EDT
I'm not sure how we want to handle this. The astronomy-bookmarks package is only intended for the Astronomy Fedora spin, but I'd really prefer if it didn't Conflict: fedora-bookmarks

Either way, I'm not sure this is a blocker.
Comment 2 Marek Mahut 2009-04-16 04:50:32 EDT
I don't think this is a blocker either. I can remove the conflict with fedora-bookmarks, but if someone installs fedora-bookmars on default installation it will rewrite default-bookmarks.html from fedora-bookmarks. What do you think is the best option?
Comment 3 Lubomir Rintel 2009-04-16 05:09:43 EDT
I'd say this is okay. If we remove the Conflict, we'll get a file conflict anyway.
Another solution would be to modify both packages to utilize an alternatives(8) system.
Comment 4 Jesse Keating 2009-04-16 14:53:17 EDT
I'm leaving this open as we'll want to prevent astronomy-bookmarks from being on the DVD and iso sets.  Moving to Preview.
Comment 5 Jesse Keating 2009-04-16 15:28:38 EDT
I updated the kickstart for the Fedora spin to exclude the astronomy-bookmarks.

Note You need to log in before you can comment on or make changes to this bug.