Bug 49264 - RFE: Please add 1152x864 100hz modeline
RFE: Please add 1152x864 100hz modeline
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Mike A. Harris
: EasyFix, Reopened
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2001-07-17 11:23 EDT by Torsten Schuetze
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-22 02:21:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Torsten Schuetze 2001-07-17 11:23:21 EDT
I have XFree86-4.0.3-5 and Xconfigurator-4.9.29-1.  Installation with my
Matrox G450 went fine so far (except the missing DRI but this is another
problem). However, after the installation X runs only with 1152x864 75Hz
although the monitor can easily run 100Hz. A quick test showed that the
relevant modelines are in /etc/X11/XF86Config, but not in XF86Config-4.
After I copied the modelines to XF86Config-4 my X server runs with 1152x864
100Hz.

BTW, the same happens with Matrox G400 (and working DRI).

Why do I have to copy the modelines manually after the installation?
Comment 1 Mike A. Harris 2001-07-24 03:16:36 EDT
Because XFree86 4 has the modelines built into the server itself.
It also accepts modelines in the config file though.  So if there
are missing modelines in 4.x, that are important, they should be added
via patching X sources rather than by us hacking Xconfigurator.

This has already been requested however, and a patch applied
to XFree86 4.1.0 in rawhide for 85Hz.  If you'd like 100hz also,
please attach the commented modeline and I will patch it into XFree86.
Comment 2 Torsten Schuetze 2001-07-24 04:40:12 EDT
This is the modeline I copied from XF86Config to XF86Config-4. It works fine for
me.

# 1152x864 @ 100 Hz, 89.62 kHz hsync
    Modeline "1152x864"   137.65 1152 1184 1312 1536
                                 864  866  885  902 -HSync -VSync

Would be fine if it would be included into XFree86-4.1.0.
BTW, what files do I need to upgrade to 4.1.0? Is it sufficient to install all  
XFree86*-4.1.0-0.8.6.i386.rpm,   Mesa*-3.4.2-3.i386.rpm and
Xconfigurator-4.9.31-1.i386.rpm
Do I have to recompile the kernel (kernel-2.4.3-12 in the moment) to get DRI
with my Matrox G450 DH working? Does there exist a document which describes the
update?
Comment 3 Chris Kuivenhoven 2004-09-04 17:37:12 EDT
This is 3 years old, and probably deprecated as well (for one, Fedora
has moved to xorg). Can this be closed?

-Chris Kuivenhoven
Comment 4 Torsten Schuetze 2004-09-06 03:08:45 EDT
Bug can be closed (It doesn't occur in XFree86-4.3.99.902 in Suse. I
had to switch to Suse because there is no retail customer version of
Redhat Linux :-()
Comment 5 Mike A. Harris 2004-09-06 07:13:26 EDT
This was closed "CURRENTRELEASE" which I believe is incorrect, unless
upstream added this modeline to xorg-x11 6.7.0 (which is in our
current release).

General purpose modelines really should be built directly into the
X server, and formulated by using the VESA GTF specification. The
proper place to have new modelines added to the X server directly
is by filing a request for enhancement to the upstream X.Org project
(or XFree86) directly.  Once the request is reviewed and resolved
by X.Org, the modeline will be available to all Linux distributions,
without each distribution needing to manually patch their X server
each OS release.

In the mean time, the modeline can easily be added by hand to the
X server config file as a simple workaround.

Take care,
TTYL
Comment 6 Mike A. Harris 2006-07-22 02:21:32 EDT
A quick check seems to show either nobody ever requested this upstream,
or if they did, Xorg never added the mode to the server.  I've added
1152x864@100 Hz calculated using VESA GTF to the Red Hat extramodes patch
for the time being as follows:

$ gtf 1152 864 100

  # 1152x864 @ 100.00 Hz (GTF) hsync: 91.50 kHz; pclk: 143.47 MHz
  Modeline "1152x864_100.00"  143.47  1152 1232 1360 1568  864 865 868 915 
-HSync +Vsync


It will be in the next X server build in rawhide (1.1.1-8.fc6)

Note You need to log in before you can comment on or make changes to this bug.