This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 49268 - quirky handling of GNOME/Nautilus backgrounds
quirky handling of GNOME/Nautilus backgrounds
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-17 11:42 EDT by Chris Runge
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-17 12:01:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Runge 2001-07-17 11:42:37 EDT
Fairfax beta 2

Description of Problem:

GNOME and Nautilus are not in sync when it comes to handling background images.

How Reproducible:


Steps to Reproduce:
1. right-click on desktop background and select "Change Desktop
Background"; select None for Wallpaper and check that GNOME is used to set
the background.
2. In Nautilus, go to Edit | Backgrounds and Emblems. Drag a pattern to the
background. The change takes effect.
3. Go back to the GNOME Control Center and select Background. It still
shows that there is no Wallpaper selected and that GNOME is being used to
select backgrounds.

Actual Results:

(see above)

Expected Results:

Ideally there should only be one interface to this. Short of that, GNOME
and Nautilus should be in sync--changes made in one interface should show
up in the other. Currently it is confusing as to what should be changed where.

Additional Information:
Comment 1 Havoc Pennington 2001-07-17 12:41:42 EDT
I've moved this bug upstream as: http://bugzilla.gnome.org/show_bug.cgi?id=57666
since it really requires a larger overhaul than we would like to do in 
Red Hat specific patches.

Nautilus does actually save its background so GNOME will pick it up, but there
are some issues. I think if the background capplet is open when you are using
Nautilus then it probably gets confused, and the interaction between the
Nautilus theme and the background confuses me. Also, there are different
defaults on first login depending on whether Nautilus or the background
properties capplet runs first.

Anyway, closing this on the Red Hat tracker, want to use GNOME bugzilla to track
this.

Note You need to log in before you can comment on or make changes to this bug.