Bug 492683 - RFE: Expose 'virDomainMemoryPeek' and 'virDomainBlockPeek' in python bindings
RFE: Expose 'virDomainMemoryPeek' and 'virDomainBlockPeek' in python bindings
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-28 02:43 EDT by Alex Jia
Modified: 2016-04-26 11:17 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 611824 (view as bug list)
Environment:
Last Closed: 2011-08-15 16:25:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Jia 2009-03-28 02:43:44 EDT
Description of problem:

the libvirt version 0.6.1-4.el5,libvirt-python version 0.6.1-4.el5,
in the libvirt.py module, in class virDomain, when blockPeek and memoryPeek functions are called,display information "libvirtmod module object has no attribute 'virDomainMemoryPeek' and 'virDomainBlockPeek'"  
 
and I have looked over libvirtmod dynamic link library(libvirt.so),
which do not have this method to export.


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
libvirt.so don't export 'virDomainMemoryPeek' and 'virDomainBlockPeek' method 

Expected results:
export this two methods

Additional info:
Comment 1 Daniel Berrange 2009-03-28 13:36:40 EDT
The libvirt.so *does* export these methods

$ nm -a -D /usr/lib/libvirt.so | grep Peek
00028770 T virDomainBlockPeek
00028590 T virDomainMemoryPeek


The problem is simply that the python bindings have not implemented wrappers for them.
Comment 2 Alex Jia 2009-03-29 03:28:09 EDT
libvirt.so does export these methods,it should be libvirtmod.so instead of libvirt.so in description of problem,Just like you said,the python bindings have not implemented wrappers for them.so when blockPeek and memoryPeek functions are called in libvrit.py,information display "libvirtmod module object has no attribute 'virDomainMemoryPeek' and 'virDomainBlockPeek'"
Comment 3 Perry Myers 2009-03-30 11:26:49 EDT
libvirt-0.6.1-4.el5 is not presently on RHEVH Node images as we are still using 0.5.1.  This bug should really be moved to RHEL5.4 instead of RHEV.
Comment 4 Daniel Veillard 2009-04-23 10:12:05 EDT
There is still no support for virDomainMemoryPeek and virDomainBlockPeek
in the python bindings upstream. I don't expect that to be added before 5.4

Daniel
Comment 5 Alex Jia 2009-05-31 21:39:28 EDT
rhel5.4-server is still no support for virDomainMemoryPeek and virDomainBlockPeek
in the python bindings upstream.


[root@dhcp-66-70-18 site-packages]# pwd
/usr/lib64/python2.4/site-packages
[root@dhcp-66-70-18 site-packages]# nm -a -D libvirtmod.so |grep Peek
[root@dhcp-66-70-18 site-packages]# nm -a -D libvirtmod.so |grep Devices
000000000000d3d0 T libvirt_virNodeNumOfDevices
                 U virNodeListDevices
                 U virNodeNumOfDevices
[root@dhcp-66-70-18 site-packages]# uname -r
2.6.18-151.el5xen
[root@dhcp-66-70-18 site-packages]# rpm -qa|grep libvirt
libvirt-python-0.6.3-3.el5
libvirt-0.6.3-3.el5
libvirt-0.6.3-3.el5
Comment 9 flying 2011-08-06 11:43:28 EDT
still no support for virDomainMemoryPeek
[root@lion site-packages] nm -a -D libvirtmod.so |grep Peek

tried with latest Version - libvirt-python 0.9.4-1
Comment 10 RHEL Product and Program Management 2011-08-15 16:25:03 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.