Bug 492684 - i915 lock error in kernel log
i915 lock error in kernel log
Status: CLOSED DUPLICATE of bug 481687
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-28 04:59 EDT by Laurence
Modified: 2009-06-15 17:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 17:27:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (59.64 KB, text/plain)
2009-03-28 05:00 EDT, Laurence
no flags Details

  None (edit)
Description Laurence 2009-03-28 04:59:49 EDT
Description of problem:

On Fedora 11 Alpha, I get the following in my log. May be the same as Moblin Bug 1381:

=======================================================
[ INFO: possible circular locking dependency detected ]
2.6.29-0.66.rc3.fc11.i686 #1
-------------------------------------------------------
Xorg/3221 is trying to acquire lock:
 (&mm->mmap_sem){----}, at: [<c048d341>] might_fault+0x43/0x80

but task is already holding lock:
 (&dev->struct_mutex){--..}, at: [<f8076fd5>] i915_gem_execbuffer+0x104/0x9fb [i915]

which lock already depends on the new lock.


the existing dependency chain (in reverse order) is:

-> #2 (&dev->struct_mutex){--..}:
       [<c044f249>] __lock_acquire+0x9b1/0xb24
       [<c044f417>] lock_acquire+0x5b/0x81
       [<c06e09c0>] __mutex_lock_common+0xd5/0x329
       [<c06e0cac>] mutex_lock_nested+0x2e/0x36
       [<f802a697>] drm_vm_open+0x25/0x37 [drm]
       [<c042db3f>] dup_mm+0x261/0x32a
       [<c042e623>] copy_process+0x9ec/0x10d4
       [<c042ee1e>] do_fork+0x113/0x288
       [<c040236a>] sys_clone+0x1f/0x21
       [<c0403af6>] syscall_call+0x7/0xb
       [<ffffffff>] 0xffffffff

-> #1 (&mm->mmap_sem/1){--..}:
       [<c044f249>] __lock_acquire+0x9b1/0xb24
       [<c044f417>] lock_acquire+0x5b/0x81
       [<c0443f62>] down_write_nested+0x3a/0x76
       [<c042d98b>] dup_mm+0xad/0x32a
       [<c042e623>] copy_process+0x9ec/0x10d4
       [<c042ee1e>] do_fork+0x113/0x288
       [<c040236a>] sys_clone+0x1f/0x21
       [<c0403af6>] syscall_call+0x7/0xb
       [<ffffffff>] 0xffffffff

-> #0 (&mm->mmap_sem){----}:
       [<c044f11e>] __lock_acquire+0x886/0xb24
       [<c044f417>] lock_acquire+0x5b/0x81
       [<c048d35e>] might_fault+0x60/0x80
       [<c053cffc>] copy_to_user+0x2c/0xfc
       [<f8077818>] i915_gem_execbuffer+0x947/0x9fb [i915]
       [<f80256d3>] drm_ioctl+0x1bf/0x23c [drm]
       [<c04b00ad>] vfs_ioctl+0x50/0x69
       [<c04b05f4>] do_vfs_ioctl+0x46a/0x4a3
       [<c04b066d>] sys_ioctl+0x40/0x5a
       [<c0403af6>] syscall_call+0x7/0xb
       [<ffffffff>] 0xffffffff

other info that might help us debug this:

1 lock held by Xorg/3221:
 #0:  (&dev->struct_mutex){--..}, at: [<f8076fd5>] i915_gem_execbuffer+0x104/0x9fb [i915]

stack backtrace:
Pid: 3221, comm: Xorg Not tainted 2.6.29-0.66.rc3.fc11.i686 #1
Call Trace:
 [<c06df7db>] ? printk+0xf/0x14
 [<c044e681>] print_circular_bug_tail+0x5d/0x68
 [<c044f11e>] __lock_acquire+0x886/0xb24
 [<c044f417>] lock_acquire+0x5b/0x81
 [<c048d341>] ? might_fault+0x43/0x80
 [<c048d35e>] might_fault+0x60/0x80
 [<c048d341>] ? might_fault+0x43/0x80
 [<c053cffc>] copy_to_user+0x2c/0xfc
 [<f8077818>] i915_gem_execbuffer+0x947/0x9fb [i915]
 [<c049fedc>] ? __slab_alloc+0x3cb/0x440
 [<c048d37c>] ? might_fault+0x7e/0x80
 [<c053cee9>] ? copy_from_user+0x2a/0x111
 [<f80256d3>] drm_ioctl+0x1bf/0x23c [drm]
 [<f8076ed1>] ? i915_gem_execbuffer+0x0/0x9fb [i915]
 [<c04b00ad>] vfs_ioctl+0x50/0x69
 [<c04b05f4>] do_vfs_ioctl+0x46a/0x4a3
 [<c0510ed1>] ? selinux_file_ioctl+0x3e/0x42
 [<c04b066d>] sys_ioctl+0x40/0x5a
 [<c0403af6>] syscall_call+0x7/0xb
Comment 1 Laurence 2009-03-28 05:00:50 EDT
Created attachment 337095 [details]
Xorg.0.log
Comment 2 Chuck Ebbert 2009-04-01 01:53:14 EDT
Can you try the beta and see if this bug is still there?
Comment 3 Laurence 2009-04-01 03:29:14 EDT
Fedora 11 Beta:

=======================================================
[ INFO: possible circular locking dependency detected ]
2.6.29-0.258.2.3.rc8.git2.fc11.i586 #1
-------------------------------------------------------
Xorg/3198 is trying to acquire lock:
 (&mm->mmap_sem){----}, at: [<c04909ef>] might_fault+0x48/0x85

but task is already holding lock:
 (&dev->struct_mutex){--..}, at: [<f7dddabb>] i915_gem_execbuffer+0xd6/0xa12 [i915]

which lock already depends on the new lock.


the existing dependency chain (in reverse order) is:

-> #1 (&dev->struct_mutex){--..}:
       [<c045062c>] __lock_acquire+0x970/0xace
       [<c04507e5>] lock_acquire+0x5b/0x81
       [<c06edeff>] __mutex_lock_common+0xdd/0x338
       [<c06ee201>] mutex_lock_nested+0x33/0x3b
       [<f7d86575>] drm_gem_mmap+0x36/0xf7 [drm]
       [<c0496ffb>] mmap_region+0x243/0x3cb
       [<c04973d5>] do_mmap_pgoff+0x252/0x2a2
       [<c0407124>] sys_mmap2+0x5f/0x80
       [<c0403f92>] syscall_call+0x7/0xb
       [<ffffffff>] 0xffffffff

-> #0 (&mm->mmap_sem){----}:
       [<c04504f9>] __lock_acquire+0x83d/0xace
       [<c04507e5>] lock_acquire+0x5b/0x81
       [<c0490a0c>] might_fault+0x65/0x85
       [<c0542983>] copy_from_user+0x32/0x119
       [<f7dddc4e>] i915_gem_execbuffer+0x269/0xa12 [i915]
       [<f7d856c7>] drm_ioctl+0x1b7/0x236 [drm]
       [<c04b3d24>] vfs_ioctl+0x5a/0x74
       [<c04b42b8>] do_vfs_ioctl+0x483/0x4bd
       [<c04b4338>] sys_ioctl+0x46/0x66
       [<c0403f92>] syscall_call+0x7/0xb
       [<ffffffff>] 0xffffffff

other info that might help us debug this:

1 lock held by Xorg/3198:
 #0:  (&dev->struct_mutex){--..}, at: [<f7dddabb>] i915_gem_execbuffer+0xd6/0xa12 [i915]

stack backtrace:
Pid: 3198, comm: Xorg Not tainted 2.6.29-0.258.2.3.rc8.git2.fc11.i586 #1
Call Trace:
 [<c06ecd86>] ? printk+0x14/0x16
 [<c044faa7>] print_circular_bug_tail+0x5d/0x68
 [<c04504f9>] __lock_acquire+0x83d/0xace
 [<c06ef227>] ? _spin_unlock+0x22/0x25
 [<c04909ef>] ? might_fault+0x48/0x85
 [<c04507e5>] lock_acquire+0x5b/0x81
 [<c04909ef>] ? might_fault+0x48/0x85
 [<c0490a0c>] might_fault+0x65/0x85
 [<c04909ef>] ? might_fault+0x48/0x85
 [<c0542983>] copy_from_user+0x32/0x119
 [<f7dddc4e>] i915_gem_execbuffer+0x269/0xa12 [i915]
 [<c044e012>] ? lock_release_holdtime+0x2b/0x123
 [<c0490a2a>] ? might_fault+0x83/0x85
 [<c0542983>] ? copy_from_user+0x32/0x119
 [<f7d856c7>] drm_ioctl+0x1b7/0x236 [drm]
 [<f7ddd9e5>] ? i915_gem_execbuffer+0x0/0xa12 [i915]
 [<c04b3d24>] vfs_ioctl+0x5a/0x74
 [<c04b42b8>] do_vfs_ioctl+0x483/0x4bd
 [<c05166b9>] ? selinux_file_ioctl+0x3f/0x42
 [<c04b4338>] sys_ioctl+0x46/0x66
 [<c0403f92>] syscall_call+0x7/0xb
Comment 4 Bug Zapper 2009-06-09 08:45:46 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Adam Williamson 2009-06-15 17:27:03 EDT

*** This bug has been marked as a duplicate of bug 481687 ***

Note You need to log in before you can comment on or make changes to this bug.