Bug 492704 - new NoClassDefFoundError exceptions
new NoClassDefFoundError exceptions
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-28 12:16 EDT by Donald Cohen
Modified: 2009-12-18 04:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 04:07:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donald Cohen 2009-03-28 12:16:24 EDT
(I think this is openjdk 1.6 -- how can I be sure?
Firefox plugins lists IcedTea web browser plugin 1.4 
 (fedora-13.b14.fc10-x86_64))

Description of problem:
I have some applets that used to work and still work on other machines but that 
now don't start - I see this:
Exception in thread "Applet" java.lang.NoClassDefFoundError: diamondedge/vb/TitledPanel
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:637)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
	at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
	at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:336)
	at java.lang.Class.getDeclaredConstructors0(Native Method)
	at java.lang.Class.privateGetDeclaredConstructors(Class.java:2406)
	at java.lang.Class.getConstructor0(Class.java:2716)
	at java.lang.Class.newInstance0(Class.java:343)
	at java.lang.Class.newInstance(Class.java:325)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:458)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:418)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:597)
Caused by: java.lang.ClassNotFoundException: diamondedge.vb.TitledPanel
	at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
	at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:336)
	... 20 more
java.lang.NullPointerException
	at net.sourceforge.jnlp.NetxPanel.runLoader(NetxPanel.java:97)
	at sun.applet.AppletPanel.run(AppletPanel.java:380)
	at java.lang.Thread.run(Thread.java:636)
java.lang.NullPointerException
	at sun.applet.AppletPanel.run(AppletPanel.java:430)
	at java.lang.Thread.run(Thread.java:636)

I wonder if this could be a case problem, since the file vbc.jar does claim to contain  diamondedge/vb/titledpanel.class

Version-Release number of selected component (if applicable):
Is this it?
java-1.6.0-openjdk-1.6.0.0-13.b14.fc10.x86_64

How reproducible:
Try this in your browser (I'm using firefox)
http://saturnids.spicenet.net/sonario/develop081125/develop081125-mysql.html
It'll complain about signatures - click run
  
Actual results:
the class not found exception

Expected results:
it should run - should show a login panel

Additional info:
Comment 1 Donald Cohen 2009-03-30 11:50:51 EDT
After reboot (unrelated, accidental) the url above now seems to work again.
Any info about what could possibly have caused the problem will still be appreciated.
Comment 2 Deepak Bhole 2009-03-31 14:30:25 EDT
It worked for me on first try.

Hard to say why it is working after a reboot suddenly though. There is no reason I can think of where reboot would make a difference. When you were getting the class not found issues initially, had you tried restarting the browser?
Comment 3 Donald Cohen 2009-03-31 14:41:20 EDT
It's hard to find a transcript now that I've rebooted, but I'm pretty sure I did try restarting the browser several times.
At least once was in order to get new copies of the jars downloaded after touching them on the server - my theory at that point was that the jar was corrupted.
Comment 4 Deepak Bhole 2009-03-31 14:47:19 EDT
Hmm, weird. A corrupted jar would have been redownloaded on the next try after restart, as the plugin verifies the size each time the browser is restarted. Well, in any case. Glad it is working now. I am going to close this. If you encounter it again, feel free to reopen.
Comment 5 Donald Cohen 2009-04-02 20:41:45 EDT
Ok, it's back.
I have a new theory.
This seems to be related to trying to exit firefox.
For reasons I don't understand, the normal exit is not working:  the window goes away but when I try to restart I get a complaint that it's still running.

$ ps laxww|grep fire
0     0  6371  3246  20   0  85000   784 pipe_w S+   pts/0      0:00 grep fire
0     0 15201  3246  20   0  87748  1260 wait   S    pts/0      0:00 /bin/sh /usr/lib64/firefox-3.0.8/run-mozilla.sh /usr/lib64/firefox-3.0.8/firefox
4     0 15218 15201  20   0 879280 232360 -     Rl   pts/0     12:44 /usr/lib64/firefox-3.0.8/firefox
[2009-04-02 17:31:14 root@number11 ~/workspace/com.sonariov1]
$ killall firefox

Now when I restart firefox I get the bug above.
I suspect that if I reboot it'll work again.

Any ideas?
Comment 6 Donald Cohen 2009-04-17 11:59:32 EDT
Since this seems to be reproducible (related to firefox shutdown and reboot) I reopen it.
Comment 7 Deepak Bhole 2009-04-17 14:54:03 EDT
So the way to reproduce this is to load the site, kill -9 firefox, restart it and try it then?
Comment 8 Donald Cohen 2009-04-17 15:04:41 EDT
That's what seems to work for me.
I'll be interested in hearing whether it works for you.
If not, it must have something to do with my configuration.

I suggest that before the kill you try exiting firefox in the normal way
(file quit or the x button) and see whether that removes the process that
otherwise has to be killed as above in order to restart firefox.
If you don't have to kill firefox then try the url to see whether successful
exit allows it to work.  If so, try killing firefox to see whether the 
difference between quit and kill is related to the problem.

I doubt that it makes any difference, but I'm running firefox from a shell
(actually a shell buffer in emacs).
Comment 9 Deepak Bhole 2009-04-21 15:29:44 EDT
I still can't get it to hang. I tried loading the applet, and then reloading it after exiting normally and after kill -9. The applet always loads up fine in all cases. Additionally, exiting either way left no jvm process behind...
Comment 10 Donald Cohen 2009-04-21 21:09:02 EDT
It occurred to me that the problem might be related to saving my tabs so I tried exiting and NOT saving them.  The next time the applet worked and in fact so did the exit of firefox.  Now I cannot reproduce the bug.  I now think the problem is in one of those formerly saved tags.  So I'll probably eventually see it again if I happen to go back to that tab.  Is there some way to find out what your saved tabs USED to be?  Then I could add one at a time to try to reproduce the problem.
Comment 11 Deepak Bhole 2009-04-22 09:11:32 EDT
Nope, looking at history one by one is the only way I can think of.. and yes, if there were other tabs open, there is a possibility that there was another applet running in them that froze up, which could cause the symptoms you are seeing.

Okay so since this is not reproducible I am going to close this. As always if you can reproduce it, please feel free to reopen!
Comment 12 Donald Cohen 2009-05-15 13:57:53 EDT
The problem has reappeared.
I've closed all tabs, then exited firefox -- which left a running process as before which I kill as before, then restart firefox.  This comes up empty, and
yet the applet above (and other related applets) fails as above.
Let me know if you have any ideas.
I guess my next attempt would be reboot, but of course we should find any
relevant info we can before doing that.
Comment 13 Bug Zapper 2009-11-18 06:37:54 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Bug Zapper 2009-12-18 04:07:52 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.