Bug 492756 - Bugzilla no longer works after "yum update"
Bugzilla no longer works after "yum update"
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: bugzilla (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Itamar Reis Peixoto
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-29 06:51 EDT by Nadav Har'El
Modified: 2009-07-27 23:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-27 23:36:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nadav Har'El 2009-03-29 06:51:50 EDT
Last week, after a routine "yum update", bugzilla installed on my system stopped working, giving bizarre database errors each time it is used.

After reading some documents on the web, I discovered that after an upgrade to bugzilla, one must run checksetup.pl. I ran it, and everything returned to normal.

The question is - why doesn't Fedora's bugzilla post-install script run checksetup.pl? How is the user expected to know he supposed to run this script, or even more fundamentally - that bugzilla was upgraded at all? After all, every time I run "yum update" dozens of packages get upgraded, and I don't pay attention to every one (most people probably don't even run yum update manually, and don't see the list of packages at all).

Thanks,
Nadav.
Comment 1 Itamar Reis Peixoto 2009-04-05 00:28:14 EDT
thats true, but bugzilla rpm already do this, please check

[itamar@localhost bugzilla]$ rpm -q bugzilla --scripts


postinstall scriptlet (using /bin/sh):
pushd /usr/share/bugzilla > /dev/null
./checksetup.pl > /dev/null
popd > /dev/null
[itamar@localhost bugzilla]$


I will make some tests, I will probably need to change to something like this, putting the commands inside a parentheses 


(cd /usr/share/bugzilla;
./checksetup.pl > /dev/null
)

I will test this as soon as possible.
Comment 2 Itamar Reis Peixoto 2009-07-27 23:36:40 EDT
I am closing this, if you have more problems please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.