Bug 492800 - Incorrect "package already installed" message
Incorrect "package already installed" message
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-29 14:57 EDT by Christoph Wickert
Modified: 2010-04-04 16:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-04 16:59:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2009-03-29 14:57:57 EDT
Description of problem:
I'm trying to install the fedora-packager group on a fresh install of F10 with all updates applied. gnome-packagekit incorrectly claims that it is already installed.

Version-Release number of selected component (if applicable):
gnome-packagekit-0.3.14-1.fc10.i386

How reproducible:
always

Steps to Reproduce:
1. Fresh install of F10
2. apply all updates
3. try to install "fedora-packager" with gpk-application
  
Actual results:
Installation fails:
"The package is already installed
The package that is trying to be installed is already installed.
More details
The packages failed to be installed"

Expected results:
Should install fedora-packager and silently skip packages that are already installed (if any).

Additional info:
I don't think it's related to bug # 467044, because it looks different and affects a different version. IMO it's more likely that it's because "fedora-packager" is the name of both a group and a package in that group.

  <group>
    <id>fedora-packager</id>
    <_name>Fedora Packager</_name>
    <_description>Tools and Utilities needed by a Fedora Packager</_description>
    <default>false</default>
    <uservisible>true</uservisible>
    <packagelist>
      <packagereq type="mandatory">bodhi-client</packagereq>
      <packagereq type="mandatory">bzr</packagereq>
      <packagereq type="mandatory">curl</packagereq>
      <packagereq type="mandatory">cvs</packagereq>
      <packagereq type="mandatory">fedora-packager</packagereq>
      <packagereq type="mandatory">git</packagereq>
      <packagereq type="mandatory">koji</packagereq>
      <packagereq type="mandatory">mercurial</packagereq>
      <packagereq type="mandatory">mock</packagereq>
      <packagereq type="mandatory">plague-client</packagereq>
      <packagereq type="mandatory">rpm-build</packagereq>
      <packagereq type="mandatory">rpmdevtools</packagereq>
    </packagelist>
  </group>

Installing the fedora-packager package first and the group afterwards works fine.
Comment 1 Christoph Wickert 2009-03-29 19:19:26 EDT
Ok, it not only affects fedora-packager but other groups as well and gets even more strange: 
- I tried development-tools and got the same error message. 
- After that I tried lxde-desktop, which worked. 
- Then development-tools again and this time it worked.
- Nevertheless gpk-application showed that development-tools wasn't installed. lxde-desktop on the other hand was.
- After restarting gkp-application development-tools was shown as installed.
Comment 2 Christoph Wickert 2009-05-12 19:28:48 EDT
Happens again, reproducable even after
- searching again in gpk-application to refresh the view
- restarting gpk-application
- reloading package lists

Every time gpk-application tells me that synaptics already is installed, but it's not:
$ LANG=C rpm -q synaptics
package synaptics is not installed
Comment 3 Christoph Wickert 2009-05-12 19:35:24 EDT
OK, forget the last comment. synaptics is obsoleted by xorg-x11-drv-synaptics. I think gpk-application should ether hide obsolete packages or return a more meaningful error. But this is something for another RFE and not related to this bug.
Comment 4 Christoph Wickert 2009-08-25 04:10:46 EDT
Still happens in F-11.
Comment 5 Christoph Wickert 2010-04-04 16:59:20 EDT
Meanwhile this was fixe, no idea when exactly, but I'm not seing it any longer in F-12.

Note You need to log in before you can comment on or make changes to this bug.