Bug 492819 - xorg-x11-drv-nouveau does not work with GeForce 4 MX 440
Summary: xorg-x11-drv-nouveau does not work with GeForce 4 MX 440
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: 11
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-03-30 04:43 UTC by Davide Repetto
Modified: 2009-07-21 00:17 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-07-21 00:17:49 UTC


Attachments (Terms of Use)
Logfiles for this bug (20.13 KB, application/octet-stream)
2009-03-30 04:45 UTC, Davide Repetto
no flags Details
screen corruption on shutdown/restart (501.40 KB, image/jpeg)
2009-05-07 17:38 UTC, Bruce Brackbill
no flags Details

Description Davide Repetto 2009-03-30 04:43:38 UTC
Description of problem:
=======================

xorg-x11-drv-nouveau does not work with GeForce 4 MX 440

Version-Release number of selected component (if applicable):
=============================================================

xorg-x11-drv-nouveau: from QA/Test Days/2009-03-26 live CD

VGA CARD:
01:00.0 VGA compatible controller [0300]: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] [10de:0181] (rev a2)

How reproducible:
=================
ALWAYS

Steps to Reproduce:
===================
Boot the live CD of QA/Test Days/2009-03-26
  
Actual results:
===============
See attached logfiles

Comment 1 Davide Repetto 2009-03-30 04:45:24 UTC
Created attachment 337190 [details]
Logfiles for this bug

Comment 2 Davide Repetto 2009-03-30 06:08:52 UTC
Smolt Profile:
http://www.smolts.org/client/show/pub_ec93e9bf-828a-4127-b353-3933bfd5ba55

Comment 3 Ben Skeggs 2009-04-03 04:24:39 UTC
How do you fare with xorg-x11-drv-nouveau-0.0.12-21.20090403git11be9a9.fc11?

Comment 4 Ben Skeggs 2009-04-09 05:27:34 UTC
This is more than likely fixed already, can you confirm that things improve after installing updates?

Comment 5 Adam Williamson 2009-04-17 18:49:48 UTC
He was running from a live CD. Davide, you can try with the Fedora 11 Beta (not sure the driver in that would be new enough) or snapshot release to give it a shot. Just running the Rawhide installer but not actually installing may also be enough of a test, I think, as it should try to run in graphical mode with nouveau.

Comment 6 Bruce Brackbill 2009-05-04 08:03:33 UTC
I have the same video card and X/nouveau is crashing on shutdown/restart.

Sometimes the screen just freezes ( mouse still moves) and other times i see " freeing fifo 0" or similar printed out to the screen.

Except for the damn shutdown/restart problem the driver appears to be working great.

Comment 7 Ben Skeggs 2009-05-04 08:12:54 UTC
(In reply to comment #6)
> I have the same video card and X/nouveau is crashing on shutdown/restart.
> 
> Sometimes the screen just freezes ( mouse still moves) and other times i see "
> freeing fifo 0" or similar printed out to the screen.
> 
> Except for the damn shutdown/restart problem the driver appears to be working
> great.  
This is a separate bug, can you file it as such and provide /var/log/Xorg.0.log etc?  Also, try and reproduce with the nv or vesa drivers!

Comment 8 Bruce Brackbill 2009-05-07 17:38:34 UTC
Created attachment 342894 [details]
screen corruption on shutdown/restart

I applied the updated initscripts-8.95-1 from koji and i am able to shutdown/restart now. See Bug: https://bugzilla.redhat.com/show_bug.cgi?id=495326

The shutdown/restart is still NOT so smooth ( fast BIOS beeps and screen corruption .. see attachment) but it does shutdown/restart now but not without a struggle. 

Note: The vertical line you see on the desktop moves horizontally across the screen upon shutdown/restart.

Comment 9 Adam Williamson 2009-05-07 18:51:20 UTC
Bruce: Ben asked you to file a separate bug. Please do. Discussing multiple different bugs in one report simply doesn't work and leads only to confusion.

Comment 10 Bug Zapper 2009-06-09 12:48:43 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 11 Adam Williamson 2009-07-21 00:17:49 UTC
Since there are insufficient details provided in this report for us to investigate the issue further, and we have not received feedback to the information we have requested above, we will assume the problem was not reproducible, or has been fixed in one of the updates we have released for the reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest update of their distribution, and if this issue turns out to still be reproducible in the latest update, please reopen this bug with additional information.

Closing as INSUFFICIENT_DATA.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.