Bug 492847 - rawhide installation stalled for 5 minutes before package installation
rawhide installation stalled for 5 minutes before package installation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-30 07:30 EDT by Matthieu Araman
Modified: 2009-04-23 15:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 15:29:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthieu Araman 2009-03-30 07:30:44 EDT
Description of problem:
Installation process looks stalled but recover at the end.
shifting to a console and making top run shows anaconda is shewing up cpu for 5 minutes.
I've got a fast new machine with 4Giga of ram and pretty fast cpu, adsl2 connection, so I consider I shouldn't see the installation processs blocked for 5 minutes.

Version-Release number of selected component (if applicable):
anaconda from rawhide boot.iso 20090326

How reproducible:
Sometimes, looks like depend of package selection and may be other parameters

Steps to Reproduce:
1. use boot.iso
2. follow the installation process
2. select the optional package category for installation
3. press next
  
Actual results:
nothing for 5 minutes.
The cursor doesn't change. The window is not redrawed.
After 5 minutes, a popup happen saying the installation will takes several minutes....
top on another console shows anaconda at full cpu.

After this, installation process complete (I doesn't work after boot but that's another pb)
 
Expected results:
The popup should occur immediately after pressing next.

Additional info:
redid another installation without selecting additional packages and looks like it was more smooth.

Could it be related to the fact that boot.iso installation load everything from network ?
I've got a very fast mirror near me but I don't know if fedora is clever enough to use it...
Comment 1 Chris Lumens 2009-03-31 11:14:46 EDT
We certainly have progress bars and wait windows for all this stuff, but it looks to me like they are just not getting displayed.  I've made a patch that looks to be helping to me, but I have a reasonably fast test machine here so I don't usually have to wait very long.  Could you please give rawhide (NOT F11 beta, which is being released today) a try and see if it's an improvement for you?  Thanks.
Comment 2 Matthieu Araman 2009-04-05 12:28:35 EDT
With boot.iso 20090404, selecting all packages to install, I no longer see a delay.
I've got a "verifying package dependancy" dialog immediately.
Mouse cursor doesn't change.
Shouldn't the cursor change to some busy status ?
Comment 3 Chris Lumens 2009-04-23 15:29:05 EDT
Only in certain kinds of windows.

Note You need to log in before you can comment on or make changes to this bug.