Bug 49288 - beta2 failed to install to the second HD in text mode.
beta2 failed to install to the second HD in text mode.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks: 634001
  Show dependency treegraph
 
Reported: 2001-07-17 14:13 EDT by hjl
Modified: 2010-09-14 17:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-18 19:58:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback (8.24 KB, text/plain)
2001-07-17 14:14 EDT, hjl
no flags Details

  None (edit)
Description hjl 2001-07-17 14:13:19 EDT
Description of Problem:

beta2 failed to install to the second HD in text mode.

How Reproducible:

Select text mode and custom install.

Steps to Reproduce:
1. Select text mode 
2. Select custom install.
3.  Use disk druid to install on the second HD

Actual Results:

After exiting from disk druid, anaconda aborted.
Comment 1 hjl 2001-07-17 14:14:44 EDT
Created attachment 23915 [details]
traceback
Comment 2 hjl 2001-07-17 14:20:45 EDT
sda6 is the existing swap partition on the first HD. The
GUI install has no probem with it.
Comment 3 Glen Foster 2001-07-17 14:56:32 EDT
This defect considered MUST-FIX for Fairfax gold-release.
Comment 4 Jeremy Katz 2001-07-18 19:08:00 EDT
Did you specify a / partition?  From the traceback, it looks almost like the
install didn't have a / partition specified.
Comment 5 hjl 2001-07-18 19:58:24 EDT
I changed my machine configuration. I cannot reproduce it anymore.
The configuration it failed is

1. sda has RedHat 7.1.
2. sdb is empty.
3. I tried to install beta2 to sdc with swap on sda.

In any case,  anaconda shouldn't crash.
Comment 6 Jeremy Katz 2001-07-22 15:53:40 EDT
I can't reproduce it at all here.  We've got more sanity checking now so that
cases which could theoretically get you to a condition like you saw should never
happen and if they do, we raise an exception that tells that this is something
which should never happen.  Unfortunately, I'd much rather raise an exception in
these cases because there's a chance that the crash dump could reveal something
about how the problem came about, but in your case, it unfortunately does not.

Note You need to log in before you can comment on or make changes to this bug.