Bug 492889 - segfault when placing call
segfault when placing call
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ekiga (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-30 11:25 EDT by Dennis Gilmore
Modified: 2009-06-24 15:43 EDT (History)
5 users (show)

See Also:
Fixed In Version: 3.2.4-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 15:43:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2009-03-30 11:25:30 EDT
Description of problem:
when placing call by ip ekiga segfaults when you hit call

Version-Release number of selected component (if applicable):
ekiga-3.2.0-1.fc11

How reproducible:
always

Steps to Reproduce:
1. place call
2.
3.
  
Actual results:
segfault

Expected results:
call to be placed

Additional info:
downgrading to pre- mass rebuild version works just fine.  there is likely an issue with how gcc-4.4.0 compiles things.
Comment 1 Peter Robinson 2009-03-30 11:42:40 EDT
Can you install the various debuginfo packages and gather a backtrace so we can confirm that it is a gcc issue as opposed to a ekiga/opal/ptlib bug.
Comment 2 Dennis Gilmore 2009-03-30 15:24:37 EDT
Program received signal SIGSEGV, Segmentation fault.
std::string::append (this=<value optimized out>, this=<value optimized out>) at /usr/src/debug/gcc-4.4.0-20090328/obj-x86_64-redhat-linux/x86_64-redhat-linux/libstdc++-v3/include/bits/basic_string.tcc:333
333	      const size_type __size = __str.size();
(gdb) bt
#0  0x00007ffff6adfaf1 in std::string::append (this=<value optimized out>, this=<value optimized out>) from /usr/lib64/libstdc++.so.6
*** glibc detected *** gdb: free(): invalid pointer: 0x00007fff30e20540 ***
======= Backtrace: =========
/lib64/libc.so.6[0x37b4c75b66]
/lib64/libc.so.6(cfree+0x6c)[0x37b4c7a02c]
gdb(c_get_string+0x245)[0x56d575]
gdb[0x4af19d]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x5333)[0x37ce6df473]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x8c3)[0x37ce6e1123]
/usr/lib64/libpython2.6.so.1.0[0x37ce66e67f]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x37ce643ce3]
/usr/lib64/libpython2.6.so.1.0[0x37ce65903f]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x37ce643ce3]
/usr/lib64/libpython2.6.so.1.0(PyObject_CallMethodObjArgs+0xd0)[0x37ce6444d0]
gdb[0x4a6c56]
gdb(apply_val_pretty_printer+0x106)[0x4a7636]
gdb(val_print+0x1ab)[0x4e102b]
gdb(common_val_print+0x92)[0x4e14c2]
gdb[0x508c39]
gdb[0x509843]
gdb(catch_errors+0x64)[0x50e424]
gdb(print_frame_info+0x64f)[0x50ae9f]
gdb[0x50b2aa]
gdb(catch_errors+0x64)[0x50e424]
gdb[0x509ea3]
gdb(execute_command+0x380)[0x44c790]
gdb[0x5147b5]
gdb[0x5154b2]
/lib64/libreadline.so.5(rl_callback_read_char+0x8c)[0x37bac27e2c]
gdb[0x5148f9]
gdb[0x513218]
gdb(gdb_do_one_event+0x2aa)[0x51444a]
gdb(catch_errors+0x64)[0x50e424]
gdb[0x49e028]
gdb[0x444889]
gdb(catch_errors+0x64)[0x50e424]
gdb[0x445206]
gdb(catch_errors+0x64)[0x50e424]
gdb(gdb_main+0x24)[0x444874]
gdb(main+0x69)[0x444849]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x37b4c1e6ad]
gdb[0x444719]
======= Memory map: ========
00400000-007e9000 r-xp 00000000 fd:00 1694287                            /usr/bin/gdb
009e8000-009f8000 rw-p 003e8000 fd:00 1694287                            /usr/bin/gdb
009f8000-00a14000 rw-p 009f8000 00:00 0 
00df7000-00e10000 rw-p 003f7000 fd:00 1694287                            /usr/bin/gdb
018ef000-08e8a000 rw-p 018ef000 00:00 0                                  [heap]
37b4800000-37b481f000 r-xp 00000000 fd:00 688135                         /lib64/ld-2.9.90.so
37b4a1f000-37b4a20000 r--p 0001f000 fd:00 688135                         /lib64/ld-2.9.90.so
37b4a20000-37b4a21000 rw-p 00020000 fd:00 688135                         /lib64/ld-2.9.90.so
37b4c00000-37b4d63000 r-xp 00000000 fd:00 688144                         /lib64/libc-2.9.90.so
37b4d63000-37b4f63000 ---p 00163000 fd:00 688144                         /lib64/libc-2.9.90.so
37b4f63000-37b4f67000 r--p 00163000 fd:00 688144                         /lib64/libc-2.9.90.so
37b4f67000-37b4f68000 rw-p 00167000 fd:00 688144                         /lib64/libc-2.9.90.so
37b4f68000-37b4f6d000 rw-p 37b4f68000 00:00 0 
37b5000000-37b5083000 r-xp 00000000 fd:00 688158                         /lib64/libm-2.9.90.so
37b5083000-37b5282000 ---p 00083000 fd:00 688158                         /lib64/libm-2.9.90.so
37b5282000-37b5283000 r--p 00082000 fd:00 688158                         /lib64/libm-2.9.90.so
37b5283000-37b5284000 rw-p 00083000 fd:00 688158                         /lib64/libm-2.9.90.so
37b5400000-37b5402000 r-xp 00000000 fd:00 688214                         /lib64/libdl-2.9.90.so
37b5402000-37b5602000 ---p 00002000 fd:00 688214                         /lib64/libdl-2.9.90.so
37b5602000-37b5603000 r--p 00002000 fd:00 688214                         /lib64/libdl-2.9.90.so
37b5603000-37b5604000 rw-p 00003000 fd:00 688214                         /lib64/libdl-2.9.90.so
37b5800000-37b5817000 r-xp 00000000 fd:00 688193                         /lib64/libpthread-2.9.90.so
37b5817000-37b5a16000 ---p 00017000 fd:00 688193                         /lib64/libpthread-2.9.90.so
37b5a16000-37b5a17000 r--p 00016000 fd:00 688193                         /lib64/libpthread-2.9.90.so
37b5a17000-37b5a18000 rw-p 00017000 fd:00 688193                         /lib64/libpthread-2.9.90.so
37b5a18000-37b5a1c000 rw-p 37b5a18000 00:00 0 
37b8800000-37b8826000 r-xp 00000000 fd:00 688247                         /lib64/libexpat.so.1.5.2
37b8826000-37b8a25000 ---p 00026000 fd:00 688247                         /lib64/libexpat.so.1.5.2
37b8a25000-37b8a28000 rw-p 00025000 fd:00 688247                         /lib64/libexpat.so.1.5.2
37bac00000-37bac37000 r-xp 00000000 fd:00 689064                         /lib64/libreadline.so.5.2
37bac37000-37bae37000 ---p 00037000 fd:00 689064                         /lib64/libreadline.so.5.2
37bae37000-37bae3f000 rw-p 00037000 fd:00 689064                         /lib64/libreadline.so.5.2
37bae3f000-37bae40000 rw-p 37bae3f000 00:00 0 
37c4000000-37c401c000 r-xp 00000000 fd:00 689041                         /lib64/libtinfo.so.5.7
37c401c000-37c421c000 ---p 0001c000 fd:00 689041                         /lib64/libtinfo.so.5.7
37c421c000-37c4220000 rw-p 0001c000 fd:00 689041                         /lib64/libtinfo.so.5.7
37c4400000-37c4402000 r-xp 00000000 fd:00 688528                         /lib64/libutil-2.9.90.so
37c4402000-37c4601000 ---p 00002000 fd:00 688528                         /lib64/libutil-2.9.90.so
37c4601000-37c4602000 r--p 00001000 fd:00 688528                         /lib64/libutil-2.9.90.so
37c4602000-37c4603000 rw-p 00002000 fd:00 688528                         /lib64/libutil-2.9.90.so
37c6000000-37c6021000 r-xp 00000000 fd:00 689251                         /lib64/libncurses.so.5.7
37c6021000-37c6221000 ---p 00021000 fd:00 689251                         /lib64/libncurses.so.5.7
37c6221000-37c6222000 rw-p 00021000 fd:00 689251                         /lib64/libncurses.so.5.7
37ce600000-37ce769000 r-xp 00000000 fd:00 1694091                        /usr/lib64/libpython2.6.so.1.0
37ce769000-37ce968000 ---p 00169000 fd:00 1694091                        /usr/lib64/libpython2.6.so.1.0
37ce968000-37ce9a3000 rw-p 00168000 fd:00 1694091                        /usr/lib64/libpython2.6.so.1.0
37ce9a3000-37ce9b1000 rw-p 37ce9a3000 00:00 0 
7fd31c000000-7fd31c021000 rw-p 7fd31c000000 00:00 0 
7fd31c021000-7fd320000000 ---p 7fd31c021000 00:00 0 
7fd320070000-7fd32008a000 r-xp 00000000 fd:00 689260                     /lib64/libgcc_s-4.4.0-20090328.so.1
7fd32008a000-7fd320289000 ---p 0001a000 fd:00 689260                     /lib64/libgcc_s-4.4.0-20090328.so.1
7fd320289000-7fd32028a000 rw-p 00019000 fd:00 689260                     /lib64/libgcc_s-4.4.0-20090328.so.1
7fd3202b5000-7fd320dbf000 rw-p 7fd3202b5000 00:00 0 
7fd320dbf000-7fd320dc8000 r-xp 00000000 fd:00 3445318                    /usr/lib64/python2.6/lib-dynload/itertoolsmodule.so
7fd320dc8000-7fd320fc8000 ---p 00009000 fd:00 3445318                    /usr/lib64/python2.6/lib-dynload/itertoolsmodule.so
7fd320fc8000-7fd320fcc000 rw-p 00009000 fd:00 3445318                    /usr/lib64/python2.6/lib-dynload/itertoolsmodule.so
7fd320fcc000-7fd321447000 rw-p 7fd320fcc000 00:00 0 
7fd321448000-7fd32235e000 rw-p 7fd321448000 00:00 0 
7fd322404000-7fd3226b5000 rw-p 7fd322404000 00:00 0 
7fd3226f7000-7fd3239c8000 rw-p 7fd3226f7000 00:00 0 
7fd3239cf000-7fd323a6d000 rw-p 7fd3239cf000 00:00 0 
7fd323a6e000-7fd323b64000 rw-p 7fd323a6e000 00:00 0 
7fd323b64000-7fd323b6b000 r-xp 00000000 fd:00 692396                     /lib64/libthread_db-1.0.so
7fd323b6b000-7fd323d6a000 ---p 00007000 fd:00 692396                     /lib64/libthread_db-1.0.so
7fd323d6a000-7fd323d6b000 r--p 00006000 fd:00 692396                     /lib64/libthread_db-1.0.so
7fd323d6b000-7fd323d6c000 rw-p 00007000 fd:00 692396                     /lib64/libthread_db-1.0.so
7fd323d6c000-7fd328df2000 r--p 00000000 fd:00 1673069                    /usr/lib/locale/locale-archive
7fd328df2000-7fd328df7000 rw-p 7fd328df2000 00:00 0 
7fd328e16000-7fd328e1b000 rw-p 7fd328e16000 00:00 0 
7fd328e1b000-7fd328e22000 r--s 00000000 fd:00 2229890                    /usr/lib64/gconv/gconv-modules.cache
7fd328e22000-7fd328e24000 rw-p 7fd328e22000 00:00 0 
7fff30dc2000-7fff30e23000 rw-p 7ffffff9e000 00:00 0                      [stack]
7fff30e7a000-7fff30e7b000 r-xp 7fff30e7a000 00:00 0                      [vdso]
ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]
#1  0x000000000049c8d4 in std::operator+<char, std::char_traits<char>, std::allocator<char> > (__lhs=<value optimized out>, Aborted
Comment 3 Peter Robinson 2009-04-01 06:20:26 EDT
Out of interest did this happen with ekiga 3.1.2?
Comment 4 Dennis Gilmore 2009-04-01 11:58:22 EDT
it did happen with 3.1.2
 i had to downgrade to 3.1.0 to have a working ekiga
Comment 5 Peter Robinson 2009-04-11 18:23:36 EDT
Can you run ekiga with the following command and attach the output "ekiga -d 4 2>output.txt". The backtrace is quite interesting as there are lots of references to python, which ekiga doesn't link against or require.
Comment 6 Peter Robinson 2009-04-25 20:07:50 EDT
Dennis, I've pulled in some fixes from upstream. Can you try the opal library from the following koji build to see if it fixes your problem?

http://koji.fedoraproject.org/koji/taskinfo?taskID=1320774
Comment 7 Peter Robinson 2009-05-01 07:10:47 EDT
Dennis, the koji build mentioned above is in rawhide now. Have you had any luck reproducing this, or is it fixed?
Comment 8 Dennis Gilmore 2009-05-01 14:38:40 EDT
It still segfaults when trying to place a call.
Comment 9 Peter Robinson 2009-05-10 06:11:55 EDT
Dennis can you install the following debuginfo packages and provide me another crash dump. Thanks!

GConf2-debuginfo speex-debuginfo glibc-debuginfo cyrus-sasl-debuginfo opal-debuginfo libv4l-debuginfo ekiga-debuginfo ptlib-debuginfo gtk2-debuginfo glib2-debuginfo evolution-data-server-debuginfo gvfs-debuginfo libnotify-debuginfo alsa-lib-debuginfo
Comment 10 Peter Robinson 2009-05-21 04:01:23 EDT
There is a new build in koji that should improve the stability of ekiga 3.2
substantially. Can you possibly try it and update the ticket.

ptlib: http://koji.fedoraproject.org/koji/buildinfo?buildID=102794
opal: http://koji.fedoraproject.org/koji/buildinfo?buildID=102815
ekiga: http://koji.fedoraproject.org/koji/taskinfo?taskID=1365837
Comment 11 Dennis Gilmore 2009-05-21 06:01:29 EDT
with these builds i dont get the segfault.
Comment 12 Peter Robinson 2009-05-21 08:27:34 EDT
Good news!
Comment 13 Bug Zapper 2009-06-09 08:49:06 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Peter Robinson 2009-06-13 10:34:50 EDT
*** Bug 505583 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2009-06-16 09:00:49 EDT
ekiga-3.2.4-2.fc11,opal-3.6.2-2.fc11,ptlib-2.6.2-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ekiga-3.2.4-2.fc11,opal-3.6.2-2.fc11,ptlib-2.6.2-2.fc11
Comment 16 Fedora Update System 2009-06-18 07:47:27 EDT
ekiga-3.2.4-2.fc11, opal-3.6.2-2.fc11, ptlib-2.6.2-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ekiga opal ptlib'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6575
Comment 17 Fedora Update System 2009-06-24 15:43:45 EDT
ekiga-3.2.4-2.fc11, opal-3.6.2-2.fc11, ptlib-2.6.2-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.