This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 492905 - 'startx' doesn't open a new ConsoleKit session any more
'startx' doesn't open a new ConsoleKit session any more
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xinit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
: EasyFix, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-30 12:43 EDT by Nalin Dahyabhai
Modified: 2014-06-18 05:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0.9-7.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-22 15:58:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2009-03-30 12:43:34 EDT
Description of problem:
Fixing bug #452156 broke 'startx' -- it needs to be opening a new session, but because XDG_SESSION_COOKIE is already set in the shell for the text session, it doesn't.

Version-Release number of selected component (if applicable):
1.0.9-5.fc11

How reproducible:
Always

Steps to Reproduce:
1. Boot to runlevel 3.
2. Log in.
3. Run 'startx'.
4. Open a terminal window.
5. Run 'ck-list-sessions'.
  
Actual results:
No new session, and your old session is not active, and isn't connected to the display.

Expected results:
New session attached to your display.

Additional information:
Unsetting XDG_SESSION_COOKIE before running 'xinit' in the 'startx' script would probably do the trick.

Note You need to log in before you can comment on or make changes to this bug.